1

I have two installations of debian on a single hard drive. One is on ext4 partition and the other is on luks partition. I first installed debian on the ext4 partition and then on luks partition.

Recently I did "sudo apt upgrade" on the debian on ext4. Since then I cannot boot into the debian on luks partition as the option to choose this installation do not appear on the starting screen. I tried to solve this by posting this question Adding debian installed on LUKS partition to boot option . But the answer didn't solve the problem.

However, the answer suggested me to "write a custom GRUB configuration entry for it in /etc/grub.d/40_custom, which will be included into /boot/grub/grub.cfg generated by update-grub".

Since the luks partition is encrypted I am having trouble doing so. So can anyone help?

  • Often better to install sudo apt-get update && sudo apt-get install lvm2 cryptsetup and manually mount your encrypted partition. Then os-prober will be able to add the encrypted install. You may be able to copy the grub boot stanza in your LVM install's boot partition to your ext4's version of grub, but probably needs those files also. I do not use LVM, but typically turn off os-prober as I have lots of old installs that I do not want in menu and it takes a long time to scan & update. I only add my current versions to 40_custom. – oldfred Aug 4 at 15:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.