0

I have created symbolic link of the mapped drive (DOS share) on Windows 7 computer 200.90.12.25. The symbolic link was created using mklink command. Trying to access this from Linux (Raspberry PI) using CIFS command, I get mount error(5): Input/output error. CIFS command and dmesg attached below.

I cannot access the DOS share from Linux because of NETBEUI. Line diagram shown below for reference.

enter image description here

CIFS command

sudo mount -t cifs -o user=username,guest,vers=2.0 //200.90.12.25/DOSA /home/pi/myNAS/myShare

dmesg (also on the Linux client)

[1027098.510573] FS-Cache: Duplicate cookie detected
[1027098.510583] FS-Cache: O-cookie c=c6d9fc6c [p=33027f2d fl=222 nc=2 na=1]
[1027098.510588] FS-Cache: O-cookie d=e8ce4e52 n=203d934d
[1027098.510592] FS-Cache: O-key=[8] '020001bd0a090c12'
[1027098.510606] FS-Cache: N-cookie c=435e27ec [p=33027f2d fl=2 nc=0 na=1]
[1027098.510611] FS-Cache: N-cookie d=e8ce4e52 n=9f19c9a0
[1027098.510614] FS-Cache: N-key=[8] '020001bd0a090c12'
[1027098.515854] CIFS VFS: cifs_mount failed w/return code = -5

As per the suggested comments, i have tried below commands. I got the same mount error(5): Input/output error

sudo mount -t cifs -o username=username,guest,vers=2.1,mfsymlinks //200.90.12.25/DOSA /home/pi/myNAS/myShare

mount.cifs

sudo mount.cifs //200.90.12.25/DOSA /home/pi/myNAS/myShare -o username=username,guest,domain=domain,mfsymlinks 

any alternative solution much appreciated.

7
  • 200.90.12.25 is the windows 7 computer, created a symbolic link (DOSA) of mapped drive (DOS Share), After typing cifs mount , i typed dmesg (the message displayed above). Aug 4, 2020 at 10:41
  • I don't think this is possible, but I'll wait and see what others say
    – roaima
    Aug 4, 2020 at 11:01
  • Didn't see it before but to define a user you should use the username key. Try username=username rather than user=username
    – TwystO
    Aug 5, 2020 at 16:06
  • Changing from user to username did not help me. I am getting same error. Aug 5, 2020 at 18:03
  • If any additional details required from my end please let me know. Aug 5, 2020 at 18:04

2 Answers 2

0

Could you please clarify your question just a bit more, you said a windows symlink is what you are trying to mount? Was this created using the mklink command on windows? I'm not sure if it would be possible to use a windows lnk file as a location to mount if that is what you are referring to attempting to mount. You might consider something like what the above poster said:

sudo mount -t cifs -o username=username,guest,vers=2.1,mfsymlinks //200.90.12.25/DOSA /home/pi/myNAS/myShare

According to the man page:

mfsymlinks Enable support for Minshall+French symlinks (see http://wiki.samba.org/index.php/UNIX_Extensions#Minshall.2BFrench_symlinks). This option is ignored when specified together with the sfu option. Minshall+French symlinks are used even if the server supports the CIFS Unix Extensions.

Possible alternative:
I know this sounds like a horrid suggestion, but if you could put a ftpd on the dos box you could use this fuse extension to mount that as a writable filesystem. I have included a link to the sourceforge page below.

Curl FTP Filesystem

1
  • Yes, I had created the symbolic using mklink command. After using mfsymlinks i got the same mount error(5): Input/output error, I tried the curlftpfs. the command i used was sudo curlftpfs //200.90.12.25/DOSA myDOSA/, I got Error connecting to FTP. Let me know if i am using the command properly.. Aug 8, 2020 at 10:41
-1

Have a look to the Microsoft documentation:
https://docs.microsoft.com/en-us/archive/blogs/josebda/windows-server-2012-r2-which-version-of-the-smb-protocol-smb-1-0-smb-2-0-smb-2-1-smb-3-0-or-smb-3-02-are-you-using

On Windows 7 you should use CIFS/SMB 2.1

I suggest you try this:

sudo mount -t cifs -o username=username,guest,vers=2.1 //200.90.12.25/DOSA /home/pi/myNAS/myShare

This seems to work for some people like mentioned here:
https://github.com/coreos/bugs/issues/2373

1
  • I tried 2.1 also, I am getting same error. Aug 5, 2020 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.