I've a laptop with an Arch installation, it has an ssd with a uefi boot partition and just one ext4 partition for the whole /. There is also an hdd with an old Windows and some swap.

Anyway after the usual pacman -Syu of a couple of days ago, the system never boot again properly. In particular when I turn on the laptop it says that it will take 10 seconds to try to load the root partition, but eventually it will fail dropping me on an emergency shell.

From the emergency shell I can see no ssd partition at all, but I also have a "rescue" usb thumb drive with another Arch installed on, and from that usb system I can mount and use the ssd partitions, so it would be safe to think that they are not broken.

I tried to use "/dev/nvme0n1p2" instead of the UUID in both /etc/fstab and on the kernel boot option, setting GRUB_DISABLE_UUID=true and running grub-mkconfig from the usb system in the ssd partition with arch-chroot, but I haven't seen any positive outcome so far.

Today I even tried to pacman -Syu again on the ssd root partition with arch-chroot and the command worked but the system is still dropping me in the same emergency shell.

What could be the problem? And, even more important, how can it be fixed??

1 Answer 1


I made some search and now I solved!

I also started this thread on the arch forum, it turned out that apparently is a bug of the nvme driver, solved in the kernel 5.7.13 (accordingly to this other post)

Now the kernel 5.8 is in the Arch Linux [testing] repo

So I took a usb key with Arch installed (if the key also has the same bug, update it too), I made a arch-chroot in the ssd / partition (I think that at this point is also important to mount the ssd boot partition in /boot), I edited the repositories in the /etc/pacman.conf enabling [testing], and then pacman -Sy linux should install linux 5.8 with the patch

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .