2

I have created a FTPS server using vsftpd.

When I use an unencrypted private key, vsftpd works fine.

rsa_cert_file=/etc/vsftpd/unenc_cert.pem

If I have to use a certificate that contains an encrypted private key, vsftpd fails to start.

vsftpd[42062]: 500 OOPS: SSL: cannot load RSA certificate

Encrypted private key:

-----BEGIN ENCRYPTED PRIVATE KEY-----
-----END ENCRYPTED PRIVATE KEY-----

Is there a way to use encrypted private key in vsftpd?

vsftpd version: 3.0.2

1 Answer 1

2

After researching/googling/testing, i was able to find that vsftpd does not have option to provide the passphrase for encrypted private key.

Options to overcome this limitation are:

  • Use unencrypted private key
  • Use encrypted private key and run the vsftpd from command line. Running vsftpd from command line will prompt for passphrase which should be entered manually every time.
  • Use encrypted private key and implement a expect script to provide password and implement a new systemd configuration instead of the standard vsftpd systemd configuration.

Already this has been raised in the bugzilla.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .