1

So I want to change the URxvt font which currently seems to be the X.Org Misc Fixed. I have tried adding the following to .Xresources: URxvt.font: xft:Fira Code:style=Retina:size=13, URxvt.font: xft:Fira Code,Fira Code Retina:style=Retina:size=13, and even URxvt.font: fixed:size=13. I have tried many other fonts also. Besides, I have tried the -fn option of urxvt command, but only fixed seems to work. Everything else returns: urxvt: unable to load base fontset, please specify a valid one using -fn, aborting.

Please help. Thank you. PS: I am on i3 and Gentoo. PPS: Output of fc-list | grep Fira https://pastebin.com/mNCfmQLE

  • Can someone tell me how to add a line break while writing a question? – Akshat Vats Jul 29 at 2:58
  • Blank line in the text causes a line break – Michel Jul 29 at 6:43
  • If you run urxvt -h, what does the options: line say? Does it include xft (indicating that you have Xft font support compiled in)? – telcoM Jul 29 at 6:43
  • options: perl,styles,combining,encodings=eu+vn+jp+jp-ext+kr+zh+zh-ext,transparent,tint,XIM,frills,selectionscrolling,wheel,slipwheel,cursorBlink,pointerBlank,scrollbars=plain+rxvt+NeXT+xterm – Akshat Vats Jul 30 at 2:48
  • 1
    @Michel Can you change your answer to include the above so I can mark it accepted? – Akshat Vats Aug 4 at 14:16
0

First, check to see if your urxvt includes Xft support by running urxvt -h, the options: line should include the string xft (thanks to the comment by telcoM for the suggestion).

If it doesn't, re-install it with xft added to your USE flags.

Then, add the following to your ~/.Xresources:

urxvt*font: xft:Fira Code Retina:size=13
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.