0

My laptop is a Lenovo Ideapad S340 14 inch. It was initially running windows. After installing Linux mint 19 my touchpad a few months back, my touchpad was working. Then it started moving on its own and freezing up altogether. I thought it might be a kernel problem and moved to Ubuntu 18.04. Though the touchpad was not working off a live cd, after install and updates, it was again working fine for a while and then the same issue. I again tried Zorin OS and the cycle repeats. Currently my touchpad has stopped working. It works for a while after resuming from sleep but freezes up after about 5-10 minutes. Doesnt work after restart too. I really dont want to go back to windows. So, please help me find a solution. I have tried:

Kernel: 5.4.0-42

~$ xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ PS/2 Generic Mouse                        id=19   [slave  pointer  (2)]
⎜   ↳ MSFT0001:02 04F3:304B Mouse               id=15   [slave  pointer  (2)]
⎜   ↳ MSFT0001:02 04F3:304B Touchpad            id=16   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Ideapad extra buttons                     id=17   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=18   [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Integrated Camera: Integrated C           id=14   [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]

And then "xinput enable and disable" but doesnt work.

lsmod shows

$ lsmod |grep touch
hid_multitouch         28672  0
hid                   126976  4 i2c_hid,usbhid,hid_multitouch,hid_generic
 

Also

~$ lsmod |grep elan
elan_i2c               40960  0

I have tried the "sudo modprobe -r and modprobe" commands too. I am a newbie here. So will need a lot of help and someone patient to explain. I would be more then happy to provide any additional info required.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.