0

Running debian/sid on a Thinkpad E460 I have found a collection of (presumably related) problems since trying to upgrade to kernel 5.x Nothing like this has ever occurred with earlier kernel versions.

The symptoms are very simple:

On suspend the machine appears to sleep (fans stop, power light begins slow flash) but is unresponsive to keyboard or power buttons. The only way to start it up again appears to be to force a reset.

On hibernate, the machine writes the image to the swap partition correctly, but then instead of the power light flashing rapidly three times and the machine shutting down, the power light continues flashing indefinitely and the machine continues to consume power. I haven't measured the level of power consumption very precisely but overnight a full battery was completely run down. If I force a reset, the machine then resumes correctly from the image it wrote.

I also tried rtcwake, and with suspend to RAM and the machine did not wake as expected.

I've looked through /var/log/syslog and the final messages prior to suspending look like this:

Jul 26 21:36:44 thinkpad systemd-sleep[2151]: Failed to stop
network-manager.service: Unit network-manager.service not loaded. Jul
26 21:36:44 thinkpad [2146]: /lib/systemd/system-sleep/network-manager
failed with exit status 5. Jul 26 21:36:44 thinkpad
systemd-sleep[2145]: Suspending system...

It doesn't seem likely to me that network manager would cause such a problem. Rather it seems that the kernel isn't communicating properly with the BIOS?

Can anyone offer any suggestions?

Thanks!

  • Have you searched any solutions? People may be more willing to help out if you show that you tried to fix it before asking. – fr0stbyte Jul 26 at 14:57
  • Check the Lenovo website for firmware upgrades to this model. – NickD Jul 26 at 15:00
  • Thanks for the two replies. Needless to say I did start by searching for solutions - on at least two separate occasions over some months I found none and took the path of least resistance which was to roll back the kernel upgrade and wait for the problem to be found and resolved. There are many many references to problems resuming from suspend, but they all involve the computer waking up and then becoming unresponsive, rather than simply refusing to wake up. – Jonathan Jul 27 at 3:11
  • @NickD a great suggestion and it turned out I was years behind the latest BIOS releases. I just installed the latest, which is only a month or two old (depending on whether you believe the Lenovo website or the copyright notice in the BIOS) but unfortunately it made zero difference to the behaviour. I also tried resetting BIOS settings to defaults in case that cleared out some malconfiguration but it also made no difference. – Jonathan Jul 27 at 3:13
  • 1
    UPDATE: For no clear reason that I can discern it started working. Maybe it needed a full power-off (rather than just a reboot) following a BIOS upgrade. In any case I think @NickD's answer was the right one. – Jonathan Jul 27 at 12:51
0

Thanks to @NickD for the suggestion, all that was needed was to upgrade the BIOS followed by a complete power down. Suspend/hibernate/resume now appear to work perfectly as before.

| improve this answer | |
  • Sadly the problem has returned. Again for no clear reason. I did reboot the computer for the first time in some while, but it also suspended and resumed a few times since then. But I have not done any upgrades of any sort in the interim. – Jonathan Aug 5 at 3:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.