1

I have some libreoffice documents stored with "encrypt with gpg key" option. Today I was quite surprised when the document opened without requesting a passphrase. Eventually I found an entry for my gpg key in the system key and password manager, Seahorse, where the passphrase could be displayed.

I conclude that I must have accidentally checked the "save in password manager" box in the pinentry dialog when I logged in the last time. A small mistake exposed a confidential document and my most important password.

This appears to be the same problem as here: but in my case free access to the document and the Seahorse entry survive beyond the timeout defined in gpg-agent.conf, after

echo RELOADAGENT | gpg-connect-agent

and even after a reboot.

I tried gnupg.conf no-allow-external-cache option, which causes a different pinentry dialog without the checkbox, but then the private key password is not accepted.

Is there a way to remove or disable that checkbox in the pinentry dialog?

Thanks.

MX-linux 18.3_x64 December 15 2017 base: Debian GNU/Linux 9 (stretch) gpg (GnuPG) 2.1.18

3

Placing no-allow-external-cache in gpg-agent.conf eliminates the checkbox.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.