5

I did a systemd-analyze critical-chain at boot on my system, vanilla Arch running on i3wm.

Now, I also have Virtualbox installed on my system. Therefore, the output from systemd-analyze critical-chain looks like this:

graphical.target @45.620s
└─multi-user.target @45.620s
  └─vboxweb-service.service @45.609s +10ms
    └─vboxdrv.service @1.645s +43.956s
      └─basic.target @1.637s
        └─sockets.target @1.637s
          └─dbus.socket @1.637s
            └─sysinit.target @1.637s
              └─sys-fs-fuse-connections.mount @6.422s +3ms
                └─systemd-modules-load.service @348ms +36ms
                  └─systemd-journald.socket @340ms
                    └─system.slice @327ms
                      └─-.slice @327ms

Note that `vboxdrv.service' takes the longest time, around 43 seconds, which is almost 90% of the total boot time.

My question is: Is it safe to disable both of these services with: systemd disable vboxdrv.service? Then, say whenever I want to run virtualbox, I can just do: systemd start vboxdrv.service?

3 Answers 3

3

The systemd disable vboxdrv.service command did not work for me.

To disable and enable the vboxdrv, I used the following commands:

systemctl disable vboxdrv.service
systemctl enable vboxdrv.service
2

There's no need to.

vboxdrv.service recompiles kernel drivers only when you update your kernel which I'm pretty sure you don't do daily. Still you can disable it.

1

In addition to reducing startup time, if you want to have fewer processes running, yes you can to stop and disable the virtualbox's services:

systemctl stop vboxweb-service.service vboxballoonctrl-service.service vboxdrv.service
systemctl disable vboxweb-service.service vboxballoonctrl-service.service vboxdrv.service

So you just need to start these services before when need to use VMs. But I tested and see it still continues to start again when reboot the system.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .