0

I'm trying to install Ubuntu Server on my laptop where Windows is installed.

Via Gparted I've downsized Windows partition and created 3 partitions for boot, fs root, and home. But when I try to setup partitions during installation wizard it keeps asking to select a boot disk despite I've chosen one already.

I've tried to select a Windows boot partition (I've seen somewhere that if boot partition is to far away, like > 100Gb then it might not boot), still same situation.

If I try to delete a partition then I got "Can't delete a single partition from a device that already has partitions"

Creating new partitions even if there is some space also not available in the menu of the disk.

Any thoughts or suggestion?

Thank you!


  • Laptop: ThinkPad W520
  • UEFI/Legacy loading
  • Legacy first
  • Windows is installed and I don't want to delete it for now
  • Ubuntu Desktop installer don't offer to install Ubuntu together with Windows(like cant see Windows). Windows partitions can be mounted in live Ubuntu
  • 2Mb grub partition added during installing Ubuntu Desktop but cant see it in loading options list of the system. Can't load Ubuntu Desktop that I've just installed. What else I'm missing?

UPD. I've added 2Mb grub partition but cant see it in loading options list of the system enter image description here

4
  • What brand/model system? UEFI install of server? Which version of Ubuntu and which server installer. I had issues with the newer gui based one and older version worked. How you boot install media UEFI or BIOS is then how it installs, and it looks like you have Windows in UEFI mode, so Ubuntu should also be UEFI. Far from start of disk issue was with old BIOS systems, not seen on newer UEFI based systems.
    – oldfred
    Commented Jul 24, 2020 at 14:45
  • @oldfred ThinkPad W520, in BIOS loading is selected UEFI/legacy, legacy first. Security boot disable option is not available, not sure it exists. Ubuntu 20.04. I've tried to install Ubuntu Desktop to see what it does, but what interesting is that installation guide doesnt offer to install Ubuntu together with Windows. But I can mount windows partition. After installation Grub load option is not available (only Windows partition and drives). Also now my partitions are 1. efi 2. mirrosoft, 3. some microsoft 16Mb, 4.windows, 5. grub, 6./ boot, 7 root 7. /home
    – Dmytro
    Commented Jul 24, 2020 at 19:28
  • Change your BIOS settings to "UEFI only" or "UEFI first". The 2MB bios_grub partition is only needed for legacy installations on GPT partitioned drives and you shouldn't mix the boot modes if Windows boots from UEFI. The installer should then find your ESP partition and install the necessary files to boot GRUB. You also don't need a separate /boot partition, only using / and /home is fine too, but it doesn't hurt.
    – Freddy
    Commented Jul 24, 2020 at 20:01
  • @Freddy thanks! changing to UEFI only helped, now I could choose boot disk. I didn't know that it was loading in legacy mode! Thanks a lot!
    – Dmytro
    Commented Jul 24, 2020 at 21:26

2 Answers 2

1

What is needed is to select UEFI only mode in BIOS. Basically it was loading in legacy mode before.

So thanks to oldfred and Freddy!

1

I had the same issue with my HP laptop. The problem is the new Ubuntu live installer. What helped was to use the 'Legacy server install image'.

Legacy server install image

After that you can do the usual update/upgrade commands:

sudo apt update
sudo apt upgrade
sudo apt dist-upgrade

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .