I’ve got a MacBook Pro running Catalina 10.15.6. I started it up this morning and noticed that Safari “failed to establish a secure connection” with any site I attempted to visit. I’m connected to my apartment’s Wi-Fi and my other devices on the network are working fine.

On the terminal, I ran

curl -v https://www.amazon.com

This produced

Connected to www.amazon.com ( port 443 (#0)
ALPN, offering h2
ALPN, offering http/1.1
successfully set certificate verify locations:
    CAfile: /etc/ssl/cert.pem
    CApath: None
TLSv1.2 (OUT), TLS handshake, Client hello (1):
LibreSSL SSL_connect: SSL_ERROR_SYSCALL in connection to www.amazon.com:443
Closing connection 0

I’ve restarted my computer, ran diagnostics, connected to a different network, and even reinstalled the OS. Nothing has changed.

What’s interesting is that it works when booting in safe mode.

I have no antivirus or VPN software.

LibreSSL’s version is 2.8.3.

1 Answer 1


It turns out that Covenant Eyes, a program I have running on my computer which has some VPN-like features, was the problem. I'm still not sure what the issue was but uninstalling it fixed everything. Reinstalling it did not recreate the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .