2

I have just installed Ubuntu 20.04 on a new PC. The motherboard is an ASUS TUF B550

The ethernet cable is not working (i.e. when I plug it in, I don't get internet access), though when I plug it in I see a solid orange light, and a green light flashing, next to the port.

The cable works in another machine.

Running lshw I see this:

barnyard@MeshifyC:~$ sudo lshw -c network
  *-usb:0                   
       description: Wireless interface
       product: 802.11 n WLAN
       vendor: Ralink
       physical id: 4
       bus info: usb@1:4
       logical name: wlx7cdd908404a2
       version: 1.01
       serial: 7c:dd:90:84:04:a2
       capabilities: usb-2.00 ethernet physical wireless
       configuration: broadcast=yes driver=rt2800usb driverversion=5.4.0-26-generic firmware=0.36 ip=192.168.1.89 link=yes maxpower=450mA multicast=yes speed=480Mbit/s wireless=IEEE 802.11
  *-network UNCLAIMED
       description: Ethernet controller
       product: RTL8125 2.5GbE Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:06:00.0
       version: 04
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd cap_list
       configuration: latency=0
       resources: ioport:f000(size=256) memory:fc500000-fc50ffff memory:fc510000-fc513fff

The USB device is a USB wifi adapter that I can currently using to type this. But it is very slow.

The Ethernet controller, by vendor Realtek has network UNCLAIMED next to it, which looks suspicious.

Could the UNCLAIMED device be related to my network cable problem? If so, how can I fix it?

2

The device does not exist yet (ip link is your friend) so there is no driver loaded. See No network with RTL8125 2.5GbE Controller on the Arch Linux Wiki for how to solve this, namely:

/> cd /tmp
/> git clone https://aur.archlinux.org/r8125.git
/> cd r8125
/> makepkg
/> ls
/> sudo pacman -U r8125-dkms-9.003.05-0-x86_64.pkg.tar.gz

For the -U parameter use the r8125-dkms-X.XXX.XX-X-x86_64.pkg.tar.gz filename that the ls command has displayed, it can be different)

Now blacklist the r8169 module (it wil not be loaded anymore)

/> sudo bash -c 'echo "blacklist r8169" > /etc/modprobe.d/r8169.conf'

Reboot now, the module r8125 should be loaded automatically. To check it:

/> lsmod | grep r8125

It should return something like:

r8125                 176128  0

If the module was not loaded automatically, you can force it to be loaded on boot:

/> sudo bash -c 'echo "r8125" > /etc/modules-load.d/r8125.cfg'

Now reboot and check if the module is loaded.

0

I soled this problem by installing the updated hardware-enablement kernel; on 18.04:

sudo apt update
sudo apt install linux-generic-hwe-18.04 linux-firmware

If you are using 16.04 or 20.04 replace 18.04 above as appropriate.

-1

I solved it by pulling out my bios/uefi battery for several minutes and it worked like a charm! It happened twice and I solved it twice this way. I did everything listed here and more but it didn't solved my problem. I didn't touch bios/uefi settings before. This is not a joke. I got the same problem with intel network adapter on Ubuntu 20.04. Terminal lshw listed my adapter as UNCLAIMED. I tried every page with the same problem but it didn't solved this issue.

1
  • 1
    This doesn't look like an answer to OP's question, this looks like you have a technical issue of your own. With this information this doesn't even appear to be an UNIX / Linux -related issue, but an issue related to your system - a better fit to [SuperUser].(superuser.com) In general you shouldn't submit a "me too" -type answer, but post a question of your own. Before posting to a new forum it's advisable to review the Help section of the community to find out what kind of question are on topic for the community, and how to formulate a good question which can be actually answered. Sep 23 at 0:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.