0

I am completely new to the ins and outs of linux. I am trying to check my drives by running an exerciser software, blast, that checks the read and write capabilities. I run write verify loop on the drives with max data of 200 bytes and 2 iterations. Frustratingly I keep on running into this error for certain specific drives /dev/sdh and /dev/sdi where it shows an error:

Error code 5 detected on /dev/sdh/ EIO I/O Error

When I run fdisk -l. The drives mention above does not even show. It goes from /dev/sdg to /dev/sdj. Is there anything I can do to fix this or some other commands I can run or things I can read/learn so I can do some further investigating.

5
  • question edited, please let me know if there are other things to run to get better information for me to provide
    – YuanL
    Commented Jul 23, 2020 at 7:09
  • Exerciser is called blast. I run write verify loop on the drives with max data of 200 bytes and 2 iterations. About 25 drives. Output is /dev/sd[LETTER] so for ls /dev/sdh it will output /dev/sdh for ls -l ___ brw-rw----. 1 root disk 8, DATE sdh
    – YuanL
    Commented Jul 24, 2020 at 4:55
  • Please add the output of ls -ld /dev/sd? to your question Commented Jul 24, 2020 at 8:02
  • 1
    Looks like the devices that would be in the sdh and sdi slots may be broken so they won't complete their initial set-up. Check the output of dmesg for errors related to those disks; the outputs of lsblk and/or lsscsi may help in identifying the disks in question, possibly by exclusion. smartctl -a /dev/sdh and smartctl -a /dev/sdi might be informative too.
    – telcoM
    Commented Jul 24, 2020 at 10:55
  • ls -ld returns the same output as ls -l. For dmesg: blk_update_request: I/O error, dev sdi, sector 0 Buffer I/O error on dev sdi, logical block 0, async page read sd 1:0:7:0: [sdi] FAILED Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE sd 1:0:7:0: [sdi] Sense Key : Aborted Command [current] [descriptor] sd 1:0:7:0: [sdi] Add. Sense: Logical block reference tag check failed sd 1:0:7:0: [sdi] CDB: Read(32) among many other errors related to sdh and sdi, seems like mainly repeats though
    – YuanL
    Commented Jul 24, 2020 at 23:54

1 Answer 1

1

You have a hardware problem, either in that disk or the controller. It is disconnecting and reconnecting when you ask it to do things.

It might be possible to get further clues from smartctl -a but basically your disk sounds broken.

1
  • oh i see. Thank you for your response
    – YuanL
    Commented Jul 25, 2020 at 22:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .