9

At least every Linux system that I worked with used the convention to switch to the non-graphical consoles by Ctrl-Alt-F1, Ctrl-Alt-F2 and so on.

Recently, I installed CentOS 6.3 on a machine. The installation is non-customized and uses Gnome 2.

To my surprise Alt-F4 switches to console. Alt-F1 then brings you back to the XServer. How can I change the keybinding to Ctrl-Alt instead of simply Alt?

It also seems to bypass Gnome's key bindings. In Gnome, I tried to define Alt-F4 as close window, but it does not work but still switches to the console.

closed as off-topic by Thomas Dickey, GAD3R, HalosGhost, Jeff Schaller, techraf Oct 8 '16 at 23:15

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Thomas Dickey, GAD3R, HalosGhost, Jeff Schaller, techraf
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Are you sure you don't just have a bad Ctrl key on your keyboard? – Michael Hampton Jan 1 '13 at 2:05
  • @MichaelHampton The keyboard itself is fine, but as it seems there was a temporary software problem. After restarting the machine, the problem is gone. – Philipp Claßen Jan 1 '13 at 13:43
  • I have this problem Too... I use Manjaro... Had you solve your problem? – user102150 Feb 6 '15 at 13:41
  • @Jao I did not find the reason why it sometimes happened, nor was I able to reliably reproduce it. As I didn't use that CentOS installation myself on a daily basis, I have only seen that strange behaviour when I initially set up the system. – Philipp Claßen Feb 6 '15 at 16:37
  • Parallels Desktop on Mac, with CentOS 6.8 Virtual Machine, same problem, ALT + F4 switches to console, ALT + F1 back to the XServer. – Albert Jun 30 '16 at 10:40
2

The problem vanished after a restart. I can only speculate about the reasons. It is possible to set CTRL per software. Maybe that happened. I didn't mess around with keymap or anything like that, so I don't know what caused the problem.

Sorry, for the false alarm. :-(

Edit:

From time to time, the problem repeats. It vanishes with a restart. I still don't know why.

Update:

Had the problem again on two Arch Linux systems. It occurred exactly after a Linux kernel update, but before the system was rebooted. After the reboot, the problem was gone on both systems.

  • 1
    Same problem on Ubuntu 18.04 with Unity, also fixed by rebooting. Interestingly, after logging back in, the window I was trying to close actually closes. Also, Alt+Left and Alt+Right (arrow keys) also flip through TTYs when the problem is occurring. This is annoying because that's supposed to go forward an backward in a web browser. – Nateowami Aug 30 '18 at 17:24
  • Same problem here. – Alexander Sandler Sep 6 '18 at 19:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.