4

I recently installed Pop!_OS on my laptop and I couldn't get grub to show up in the boot screen. My laptop just keeps showing me a black screen at startup and then boots directly into Pop. I've tried editing my grub config file to show the menu for 6 seconds before booting into the OS:

`GRUB_TIMEOUT=6,GRUB_TIMEOUT_STYLE=menu`

But it keeps booting the same way it used to before editing the file.

I have the latest version of grub.

For the record, I don't have any dual boot setup, just the Pop!_OS. But I do plan to install Windows as a dual boot setup, that's why I'm trying to get grub working properly.

Edit: I found out recently that Pop!_OS uses systemd-boot as the bootloader, and had installed grub manually. But i think Pop!_OS still detects systemd-boot as the default bootloader. Is there any way to remove systemd-boot and use grub or maybe use systemd-boot as a boot menu (I just want a functioning boot menu for my dual boot setup as I mentioned).

2
  • Pop!OS does not use grub, it uses SystemD-Boot. So editing grub settings will not make any change unless you are not using the default SystemD boot. manpages.ubuntu.com/manpages/cosmic/man7/systemd-boot.7.html – oldfred Jul 20 '20 at 23:19
  • actually i installed grub manually, thinking it would override systemd boot. but if it's still there, how do i remove it safely ? – SvgG0D Jul 20 '20 at 23:43
3

Pop!_OS uses systemd-boot instead of GRUB. By default it boots Pop!_OS. You can set a boot menu timeout by setting timeout 10 in /boot/efi/loader/loader.conf.

timeout – menu timeout in seconds before the default entry is booted. If this is not set, the menu will only be shown on space key (or most other keys actually work too) pressed [repeatedly] during boot.

  1. Open /boot/efi/loader/loader.conf for editing in nano text editor.

     sudo nano /boot/efi/loader/loader.conf
    
  2. Add a new line that says timeout 10

  3. Save the file. Press the keyboard combination Ctrl+O and after that press Enter to save the change that was made to /boot/efi/loader/loader.conf. Press the keyboard combination Ctrl+X to exit nano.

6
  • actually I did all of the steps, still nothing. My grub version is 2.04 as i checked from grub-install --version – SvgG0D Jul 20 '20 at 23:49
  • My loader.conf file has only one line in it, "default Pop_OS-current". Should i add the timeout line ? Also, is there anyway to make the boot menu show up by default without having to press any keys? That would be awesome. – SvgG0D Jul 21 '20 at 6:16
  • Add a new line to loader.conf that says timeout 10 For more information see Options section of loader.conf manual. – karel Jul 21 '20 at 7:14
  • It's working. :D Thank you!!! Last question tho, can i remove grub now safely ? – SvgG0D Jul 21 '20 at 8:07
  • First run apt search '^grub' | grep installed to list which grub packages are installed. Then run apt remove --simulate package-name to simulate removing the grub packages, one package at a time. You don't need to use sudo because it's just a simulation. Check the results to see if the simulated grub package removal would break anything, before you uninstall any packages for real. – karel Jul 21 '20 at 8:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.