1

As of today, I am unable to enable all three of my monitors at their preferred resolution (2560x1440). This configuration has been working for the last two weeks without error. I had unplugged the laptop and monitors from the dock this weekend so I could hook the monitors up to my gaming PC. I plugged everything back into the dock this morning. There have been no software updates as far as I am aware.

I get the following error when attempting to enable all three monitors:

xrandr: Configure crtc 2 failed

Hardware

Software

  • OS: Debian Testing
  • Window Manager: i3wm

Note: All of the external monitors show up as DP-1-{1,2,3} even though one of these cables is HDMI; not Displayport. I recall that the monitors previously (when the three monitor set-up was working) showed as DP-2-{1,2,3}.

Things I Have Tried

  1. Turning the laptop off and on again.
  2. Un-mounting the laptop, turning it on and logging in while off the mount, then turning it off again to put it back on the mount.
  3. Plugging and unplugging the monitor cables from the mount while the laptop is running
  4. Activating each of the two-of-three sets of monitors (eg: Dell1 and Dell2, Dell1 and HP, etc) at preferred resolution (2560x1440). This works without error.
  5. Activating all three monitors with one of the three at a reduced resolution (Dell1 2560x1440, Dell2 2560x1440, and HP 1920x1080). This works without error.
  6. Adding custom resolutions (2552x1440_60.00 59.94, 2048x1152_60.00 59.90, 2480x1395_60.00 59.97) and setting the third monitor to these resolutions. 2048x1152_60.00 59.90 worked; the other two didn't work.

arandr layout output (formatted for reading):

#!/bin/sh
xrandr \
  --output eDP-1 --off \
  --output DP-1 --off \
  --output HDMI-1 --off \
  --output DP-2 --off \
  --output DP-1-1 --mode 2560x1440 --pos 4898x2033 --rotate left \
  --output DP-1-2 --mode 2560x1440 --pos 2338x1846 --rotate normal \
  --output DP-1-3 --mode 2560x1440 --pos 2338x3286 --rotate normal

xrandr --verbose with the two Dell monitors enabled: gist.

2 Answers 2

3

I was able to set all monitors to 2560x1440 by setting the third monitor to a lower refresh rate. My current configuration has the two Dell monitors at 2560x1440 is:

DP-1-1 connected 1440x2560+0+320 right (normal left inverted right x axis y axis) 610mm x 356mm
   ...
   2560x1440_30.00  29.94*
DP-1-2 connected primary 2560x1440+1440+0 (normal left inverted right x axis y axis) 597mm x 336mm
   2560x1440     59.95*+ 143.91
DP-1-3 connected 2560x1440+1440+1440 (normal left inverted right x axis y axis) 597mm x 336mm
   2560x1440     59.95*+ 143.91
#!/bin/sh
xrandr \
--output eDP-1 --off \
--output DP-1 --off \
--output HDMI-1 --off \
--output DP-2 --off \
--output DP-1-1 --mode 2560x1440_30.00 --pos 0x320 --rotate right \
--output DP-1-2 --primary --mode 2560x1440 --pos 1440x0 --rotate normal \
--output DP-1-3 --mode 2560x1440 --pos 1440x1440 --rotate normal

I created the 2560x1440_30.00 mode by following the steps on the archlinux wiki:

  1. Use cvt to create a modeline: cvt 2560 1440 30
  2. Create a new mode in xrandr: xrandr --newmode "2560x1440_30.00" ...
  3. Set the third monitor to use this new mode in arandr, you could also use xrandr.
1
  • This was a lifesaver for me. Thanks! For Apple 27-inch Cinema Display I had to use cvt 2560 1440 47
    – mFat
    Commented Aug 20, 2022 at 18:53
0

I thought I'd add my solution so someone else might profit

I was also stuck on xrandr: Configure crtc 2 failed too but it took a bit more tinkering than the initial solution for both my external monitors (all 3 when including the internal one) to work at 60Hz.

My issue was that only ever ONE monitor would work - and I couldn't activate the other one.

The sequence that eventually worked was:

  • activate one of the monitors before the other one (changing the sequence meant it wouldn't work, DP-2-2 first in my case)
  • set this monitor to 60Hz vs the default 75Hz: xrandr --output DP-2-2 --mode 2560x1440 --rate 60
  • create a mode for 30Hz: gtf 2560 1440 30 to get settings and xrandr --newmode "2560x1440_30.00" 146.27 2560 2680 2944 3328 1440 1441 1444 1465 -HSync +Vsync to create the mode
  • add this mode to the other monitor: xrandr --addmode DP-2-3 "2560x1440_30.00"
  • activate this monitor using the 30Hz-mode (activating at another frequency didn't work): xrandr --output DP-2-3 --mode 2560x1440_30.00
  • [now both monitors are active]
  • set the monitor to 60Hz xrandr --output DP-2-3 --mode 2560x1440 --rate 60

Somewhere along the way I also reset my gnome to get the right monitor to activate first (not recommended, deletes gnome settings! dconf reset -f /org/gnome/). I also played around using the gnome display-settings GUI - right-click on desktop - to get to this sequence in the first place.

I'll be trying to combine all this into a script that I can run after startup, but at least I know there's a working sequence.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .