1

Two months ago, I decided to try openSUSE for the first time. After trying both the rolling release and stable versions, I concluded that I didn't like either of them. So, I just resorted to installing KDE Neon. I downloaded the ISO file from the official site, as usual, and then, I burned it using a startup disk creator, as usual. I don't remember if I used the native openSUSE program or GNOME Multiwriter because I didn't think it would matter at the time.

In the next two months, I experimented with a lot of programs and features on KDE Neon. Fast-forward to last week, I decided it would be a good idea to make a fresh install to get rid of any files that were left of the intense experimentation. So, I would simply format the USB drive and burn a newer KDE Neon ISO image on it. I tried to format it with the KDE Partition manager utility, but then, I realized something was different. I couldn't format it, because it was read-only.

Nothing within KDE Partition manager helped, so I installed Gparted. Nothing, it displayed a message saying that it couldn't format the ISO9660 partition nor create a new partition table. Then, I tried a lot of commands. Some of them. And, BTW, the USB doesn't have the physical switch to protect it.

sudo dosfsck -a /dev/sdb
fsck.fat 4.1 (2017-01-24)
open: Read-only file system

sudo mkfs /dev/sdb
mke2fs 1.44.1 (24-Mar-2018)
/dev/sdb contains a iso9660 filesystem labelled 'neon user 20200409-11:26'
Proceed anyway? (y/N) y
/dev/sdb: Read-only file system while setting up superblock

sudo fsck.vfat -f -v /dev/sdb
fsck.fat 4.1 (2017-01-24)
open: Read-only file system

sudo hdparm -r0 /dev/sdb && sudo dd if=/dev/zero of=/dev/sdb
/dev/sdb:
setting readonly to 0 (off)
readonly      =  0 (off)
dd: failed to open '/dev/sdb': Read-only file system

I'll also put the output of lsblk:

NAME                  MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
loop0                   7:0    0    55M  1 loop  /snap/core18/1880
loop1                   7:1    0  29.8M  1 loop  /snap/snapd/8140
loop2                   7:2    0  29.9M  1 loop  /snap/snapd/8542
loop3                   7:3    0    55M  1 loop  /snap/core18/1754
sda                     8:0    0 931.5G  0 disk  
├─sda1                  8:1    0   731M  0 part  /boot
└─sda5                  8:5    0 930.8G  0 part  
   └─sda5_crypt        253:0    0 930.8G  0 crypt 
      ├─neon--vg-root   253:1    0 929.8G  0 lvm   /
      └─neon--vg-swap_1 253:2    0   976M  0 lvm   [SWAP]
sdb                     8:16   1  29.5G  0 disk  
├─sdb1                  8:17   1   1.5G  1 part  
└─sdb2                  8:18   1   2.3M  1 part  
sr0                    11:0    1  1024M  0 rom

So, according to my previous knowledge, and confirmed by what I read, ISO9660 isn't writable. If a drive had that file system, it would work as an expensive CD. Still, I thought there could still be a way to empty the drive. After all, to use a drive to install a distro, it has to use the ISO format. That's what I don't understand. I've created bootable USB drives a lot of times. I even tested two versions of openSUSE, so the drive was ok until I used it to install KDE Neon. Something that I've definitively done at least ten times without any issues. I can't wrap my head around what could have happened. If someone had any ideas, I would be very grateful.

7
  • 1
    Reset USB flash that was dd'd to make it usable again, reuse askubuntu.com/questions/939230/… & help.ubuntu.com/community/mkusb#Re-use_the_pendrive
    – oldfred
    Jul 19 '20 at 3:27
  • @oldfred thanks for answering, I tried that solution. It says again that the file system is read-only. I think the wise thing to do is buy a new USB drive. It would be great if I could find out what happened, though. dd: failed to open '/dev/sdb': Read-only file system 64.0KiB 0:00:00 [ 124MiB/s] [ <=>] Jul 19 '20 at 4:57
  • Just out of curiosity, what happens if you type the following? for x in /dev/sdb*; do wipefs -a $x; done Jul 19 '20 at 5:12
  • 1
    When you have tried in different computers, removed all other USB devices and rebooted, and the device /dev/sdx of your drive is read-only we can conclude, that the drive is damaged beyond repair. Sorry, but things like this happen with USB pendrives and memory cards.
    – sudodus
    Jul 19 '20 at 6:41
  • 1
    It is hard to see, from what you have written, what is not working. However you need to not write to the file-system. You need to write to the partition-table (that is not in the file-system). It should be written to /dev/sd? (there ? is a letter), not to /dev/sd??. Where ?? is a letter and number. Jan 20 '21 at 17:14
0

I remember this question on stack exchange to be the most detailed one.

Among that post I think the answer by mnemonic will do the job. You can post further updates if you are stuck.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.