0

I have installed Manjaro Linux with 5.7.0-3-MANJARO kernel. The problem is that every time I boot the system, I have to start my NetworkManager module manually with the command sudo systemctl start NetworkManager. I want my system to start it automatically. I tried adding it as a cron job with crontab -e, but it does not work. How do I fix this?

3
  • Can you edit into the question the output of systemctl status NetworkManager please from before you run the start?
    – icarus
    Jul 18, 2020 at 16:32
  • @icarus, inactive service Jul 18, 2020 at 16:47
  • If this is all the output from running the command, can you add the contents of /lib/systemd/sys/NetworkManager.service to the question.
    – icarus
    Jul 18, 2020 at 23:58

1 Answer 1

1
  • Do not try to use cron for this !
    Cron is meant to run repeating tasks. If you try to do it with cron it will constantly run this command again (it doesn't do any real damage but that doesn't make it a good idea either

  • Correct solution: sudo systemctl enable NetworkManager
    (The difference between enable and start is that enable will make sure that from that moment on it will always happen when the system is started)

1
  • Oh! Okay. Thanks :) Also, can you please tell me if Arch does not have an init.d by default or I have messed up the installation? From what I know, Arch is systemd, meaning init.d is a must Jul 30, 2020 at 2:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.