1

I want to boot the Win10 installer with grub chainloading. So I copied the contents of the Win10 iso to an exfat partition (also tried ntfs) on my USB storage device and typed chainloader (hd0,gpt3)/efi/microsoft/bootx64.efi into the grub shell, but I then get this error:

/EndEntire
file path: /ACPI/(a0341d0,0)/PCI(2,1f)/Sata(0,0,0)
/HD(1,800,32000,27314ea3b7ee7f43,2,2)/File(\efi\boot)/File(bootx64.efi)
/EndEntire

Since I cannot disable secure boot in my BIOS (no option in Security and Boot menu of my Lenovo Ideapad Y580), I then issued the command set check_signatures=no before entering the chainloader command as suggested here: Grub-EFI: disable signature check, but I get the same error.

Is this a problem with secure boot like here: Windows 8 UEFI does not boot? The error message is quite similar, but it does not say "error: cannot load image" and issuing set check_signatures=no doesn't help. I don't want to use rEFInd, because I installed GRUB on my USB device to also boot from a Manjaro image.

I post this question because I'm not entirely sure, if this is a problem with secure boot and also set check_signatures=no doesn't seem to work.

3
  • Try using backslashes instead of forward slashes in the chainloader command. Both are supposed to be supported, but there might be a firmware bug.
    – telcoM
    Jul 20 '20 at 11:44
  • @telcoM Thank you for your suggestion: Using backslashes does not work. It says "error: invalid filename" with chainloader (hd0,gpt3)\\efi\\microsoft\\bootx64.efi and "error: file ... not found" with chainloader (hd0,gpt3)/efi\\microsoft\\bootx64.efi Jul 20 '20 at 15:47
  • I don't think that the exfat file system is the best for this purpose. If you want to create a USB boot drive with the Windows installer, you can try with mkusb. You can also 'do it yourself' according to this link.
    – sudodus
    Jul 20 '20 at 18:19
0

As the grub manual states, the chainloader command does not work with secure boot enabled.

1
  • 1
    And yet, there are distributions such as Debian 10, which have managed to make the chainloader command work with Secure Boot. Instead of using GRUB 2.04, Debian uses 2.02 with distribution patches applied. Perhaps those patches include something that satisfies the Secure Boot requirements in another way and allow chainloader to work? The restrictions in the GRUB manual seem to be implemented by the shim_lock GRUB module, which does not seem to exist in Debian's GRUB 2.02.
    – telcoM
    Sep 10 '20 at 13:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.