I downloaded a game. It has a issue of just not working every time I launch it I'm welcomed by a white screen.

Did some cli magic, found out that the game is missing few libraries, installed them. The game still doesn't work, as far as I was able to find out it has trouble loading libsteam_api.so which I can't find a fix for too. The game has few launch scripts, and when launched with one it generates a .dmp file, running file shows the file type as: Mini DuMP crash report

* found old discussion on steam which suggested that my gpu just isn't fast enough, but I'm still going to try and fix it

  • Exactly the same situation trying to run alien isolation it crashes when I try to force it to use Nvidia. It falls back on Mesa software rendering Jun 15, 2023 at 13:59

1 Answer 1

cargo install minidump-stackwalk

minidump-stackwalk /home/dev/.local/share/feral-interactive/AlienIsolation/crashes/565dabb2-f810-712b-0ae6b3e7-76c9445e.dmp

And miraculously from running other apps I found something that worked here too. =-O >.< 8-)

Xephyr :99 -resizeable -screen 1280x720 &

LD_LIBRARY_PATH=./lib/x86_64 DISPLAY=:99 ./bin/AlienIsolation


LD_LIBRARY_PATH=./lib/x86_64 ./bin/AlienIsolation

It was completely unrelated to the crashbdump that gave me nothing. Except an indication that I might have destroyed pulse audio in the trouble shooting

0x7f34fc77d000 - 0x7f350c77cfff  memfd:pulseaudio (deleted)  ???

Don't know what that means. But I don't have audio. Although it works in cvlc... Will investigate

The rest was.

Crash reason:  SIGSEGV
Crash address: 0x000000000000d801 **
    ** Null pointer detected with offset: 0x000000000000d801
Crashing instruction: `cmp byte [rbp + 0xd801], 0x0`
Memory accessed by instruction:
  0. Address: 0x000000000000d801
     Size: 1
Process uptime: not available

Thread 0  (crashed)
 0  AlienIsolation + 0x65042b
     rax = 0x00007f350d11df60    rdx = 0x0000000000000001
     rcx = 0x0000000000000000    rbx = 0x0000000000001f01
     rsi = 0

That's always good to know. If I don't use zephyr whatever that is it calls into a pointer to zero! Calling an object that doesn't exist. Crashes every time

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .