1

I have recently installed a nVidia Tesla K80 graphics accelerator into an existing dual-socket workstation running Ubuntu 20.04 with a low-energy consumption nVidia Quadro NVS315. After updating the nVidia drivers (from legacy 390 that were needed for the Quadro to 450 in order to support CUDA on the K80), the now unsupported Quadro is stuck at a resolution of 640x480, leaving me unable to use xrandr to introduce additional custom resolutions. I have already asked the friendly folks at nVidia and they have confirmed that it is indeed a driver issue (as the Quadro is a legacy GPU by now) and that it is not possible to use two different nVidia drivers in parallel.

I have also tried to use Nouveau but I was unable to turn it on only for the Quadro in "Software & Updates/Additional Drivers", all the entries apart from "Continue using a manually installed driver" are greyed out for the Quadro if the nVidia-proprietary 450 driver is activated for the Tesla. If I switch both devices to Nouveau I have the full resolution but I can't run code on the Tesla.

As it is close to impossible to code on 640x480, I would like to ask if there is a way to force the Quadro running on the manually installed drivers to use a higher resolution or if I can force Ubuntu to use Nouveau only for the Quadro, while using the 450 drivers for the Tesla. Any hints are appreciated.

Thanks for taking your time. :)

2
  • @ArtemS.Tashkinov Hey Artem, I have already asked this question there (see the link in the first paragraph) but they were not able to answer it so far.
    – 2b-t
    Jul 16, 2020 at 19:53
  • For everybody running into the same issues: I increased the Grub2 frame buffer resolution to the highest possible rate 1024x768, so I can use the nVidia driver while working with CUDA. For normal desktop use I will turn on the Nouveau driver in "Software & Updates/Additional Drivers" and can get the full resolution on the NVS 315 but without being able to use CUDA.
    – 2b-t
    Jul 18, 2020 at 20:32

1 Answer 1

0

I came across two possible solutions that both worked for me

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.