7

I am running Red Hat Enterprise Linux Server release 7.8 (Maipo) and when I try to run.

yum install epel-release

No package epel-release available.

Error: Nothing to do

I need to install this for DKMS

2 Answers 2

14

Run:

yum install https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm

You have to do this because epel-release package is directly available in CentOS base repository, but not in RHEL repository.

According to documentation, it is also recommended to enable some optional repositories:

subscription-manager repos --enable "rhel-*-optional-rpms" --enable "rhel-*-extras-rpms"  --enable "rhel-ha-for-rhel-*-server-rpms"
2

Run the command below as http: (not https:):

yum install http://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm

to avoid the error:

Cannot open: https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm. Skipping.
3

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .