0

I'm using LibreOffice Impress on Arch Linux to make a presentation. When I embed a video into my presentation, the video initially plays fine, but gets distorted after a few seconds. The distortion seems to involve a combination of screen tearing, flickering, and other things. I read here that LibreOffice requires gstreamer to play videos, so I have installed Arch's gstreamer package as well as all of the associated plugins packages. I also tried using different video formats and different codecs, but that didn't help.

1

I was able to work around this problem by changing the SAL_USE_VCLPLUGIN environment variable in the file /etc/profile.d/libreoffice-still.sh. Originally, all lines in that file were uncommented, which I think made SAL_USE_VCLPLUGIN default to gtk3. I seemed to fix the problem by uncommenting the export SAL_USE_VCLPLUGIN=gen line. Unfortunately this option makes the user interface not look as good, although it still seems to be functional.

pre-2021 note

This answer has been updated. Prior to 2021, one of the options in /etc/profile.d/libreoffice-still.sh was export SAL_USE_VCLPLUGIN=gtk. That option made embedded videos play well and made the user interface look nice. However, this option is no longer available. I also tried adding it manually but it doesn't seem to have the same effect.

references:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.