15

Is there any way to disable KWin compositing effects from command-line? AFAIK it's possible to disable it via System settings->Hardware->Display and Monitor->Compositor but it requires a KWin restart.If I'm able to disable the compositor from command line , then I can easily assign a shortcut to it.

Any idea?

BTW I use KDE Plasma 5.19.

3 Answers 3

22

To disable compositing:

qdbus org.kde.KWin /Compositor suspend

To enable compositing

qdbus org.kde.KWin /Compositor resume
6
  • I get Service 'org.kde.KWin' does not exist..
    – Zamicol
    Commented Sep 16, 2022 at 18:26
  • 1
    @Zamicol The answer worked two years ago, I don't follow KDE development, so I can't say what works nowadays. I'll check if it's changed. Commented Sep 19, 2022 at 9:17
  • 1
    I've checked the latest preview build of KDE, i.e. KDE Plasma 5.25.90, KDE Frameworks 5.98.0 and it works just fine: imgur.com/a/XhZjH2t Commented Sep 19, 2022 at 9:27
  • Still works fine in 2022 on Plasma 5.26.4
    – tobek
    Commented Dec 7, 2022 at 3:01
  • 1
    @AlbertoSalviaNovella thanks for the info. I consider 6 an early beta, so hopefully this feature will be returned. Commented May 6 at 9:06
7

Shift + Alt + F12 is the droid you are looking for.

0
0

When I turned on compositing, it broke the setting window so I couldn't turn it back off again.

I logged in using gnome/mate, opened plasma-open-settings and was able to disable it again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .