0

My flash drive, a Transcend 16GB USB 3.1, with a built-in LED, has a new lighting pattern that correlates with Fedora 32 Linux, kept evergreen, on my Dell Latitude E6400 laptop, failing to automount it.

None of the hardware is new. The thumb drive is the youngest of the hardware, is probably 6-12 months old, and is in daily use. I've had F32 since it came out as an update to F31 and I don't remember when I started using Fedora continuously through today; perhaps that's since 2016. But the problem began only in the last few weeks. While I have used it in Windows machines I don't maintain, I haven't inserted it into any machine except my two Linux laptops since long before the problem began and no one else uses my laptops. I don't know if it began after some particular F32 update or which one. I only do the updates offered by Fedora's Software app.

Traditionally, the LED was either on or off, changing state crisply. Sometimes it is on steadily; sometimes it flashes. When everything is working, it still does this.

The new pattern is to fade and brighten slowly, with a rhythm of about 1.5-2 seconds from peak to peak. With that pattern, the Files app (Nautilus) fails to see the drive and neither do a terminal or apps, such as gedit's Open dialog.

I've tried the CLI commands mount and fdisk but, when this problem is happening, the flash is not listed in the terminal. I've tried using mount to mount everything, but that made no difference. I don't think I should reformat it; once it mounts, it's fine.

I used it in multifunction printers, a Xerox AltaLink C8045, a Xerox J-A133, and a Canon ImageRunner Advance C5540i (perhaps more than one of each), to print from USB, with no visible problem then. The Xerox machines don't say when to yank; the LED stays steadily on after it's done and I should be able to pull it out; I pull it when I no longer have a choice (other than to wait an arbitrarily few seconds and hope no other customer starts bellowing). Since I've used Canons and Xeroxes for years without this problem beginning, I doubt those machines are causing the problem at my laptop.

The problem is intermittent. When I solve it, I don't know what I did that solved it that didn't fail some other time. I've tried both USB ports on the laptop; the port I rarely use had the same problem and also worked without a problem. I've tried another flash drive (a Kingston 1GB with LED) without a problem. I've tried this flash drive (the Transcend) in another laptop (E4300 running Ubuntu Linux) without a problem. I've changed my sequence of steps (plugging in before or after waking from sleep, after but before or after logging in past Dell Setup, and after logging into my Linux user account but before or after opening the Files app); if these were effective sometimes, they were ineffective at other times. I've tried putting the laptop to sleep and then waking it almost immediately or after at least 15 seconds (so RAM can be flushed), after at least 30 seconds, after some minutes, or after some hours; I've tried warm- and cold-rebooting; if any of these sometimes worked, it didn't always work. Maybe it will be solved on the first attempt, but it can take as much as half an hour of various attempts before something finally works.

Once it is solved, it does not recur before sleeping, restarting, or powering off, even if that lets me work uninterruptedly for a lot of hours.

I'm planning to replace it in case the problem is with the flash drive, but I'm not sure that's the problem. I can't replace it with the same flash drive model, which isn't sold anymore.

I haven't found more by Googling.

Edits:

--- During a time when the flash drive had failed to mount, I checked the Files app for Other Locations for /run/media/ for my logged-in account and found that /run/media was empty. When, later, the drive had mounted, /run/media/ was present for the logged-in account but /run/media/ was absent for a nonroot account for which I can log in with a different password but for which I had not currently logged in. So, maybe, the problem is that logging in is not creating the account directory in the /run/media parent directory. Then, during a failure time, I created the child directory in /run/media (thus /run/media/), unplugged the drive, tried it in another port where it also failed, and tried another port, where it worked; maybe that was a coincidence.

--- I banged the laptop and the flash drive (separately) in case dirt was in either connector, but doing so made no difference.

--- When the thumb drive failed in one port, I tried unplugging from and replugging into the same port; that worked at least once. I've tried all four ports without an extension, with results varying. Every port often fails; any port might sometimes succeed.

--- Occasionally, the LED doesn't light at all.

--- Occasionally, the LED stays lit even during sleep.

--- When the LED lights crisply, I think the first blink off and on is when it automounts, but I'm not sure.

--- Being on the Internet doesn't matter; I don't have wired service but I have wireless and sometimes networking is off, with no difference.

What should I try next?

1 Answer 1

1

I think the problem was that the thumb stick was dying. Fortunately, it had an LED, a technology disappearing from devices of this kind, and the LED gave important clues during both health and illness. I was able to back it up when I hadn't plugged it in for about 3-5 days and then plugged it in and it immediately went into crisp-lighting mode and got mounted. I carefully did nothing to disturb making the backup, for example I did not open my browser, and it finished (my check is to count total files on the original and on the backup). Soon, I want to compare the backup to the previous backup to find what changes I made and then my data will be okay (not that I'll have a choice). Meanwhile, I left the flash drive in the machine overnight without putting it to sleep; the screen locked; when I unlocked the screen hours later with the flash drive's LED on steadily, it had already unmounted, which it shouldn't have. I put the laptop to sleep, the flash drive's LED was still on steadily (the laptop shouldn't be writing during sleep and probably isn't), and I unplugged the stick. I waited a few more days and mounted it to try to erase and reformat it to prevent data recovery by anyone else, but the attempt resulted in unmounting it; so I guess I'll twist it in pliers to destroy the interior. I already got two replacement flash drives with LEDs.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .