3

I am trying to unlock my root encrypted Debian Buster on an acepc T11. I installed dropbear, added

DEVICE=enp1s0
IP=:::::enp1s0:dhcp

to /etc/initramfs-tools/initramfs.conf and executed update-initramfs -k all -u. When the initramfs is loaded, I get multple times the error

ipconfig: enp1s0: SIOCGIFINDEX: No such device
ipconfig: no devices to configure

and a single time the error

/scripts/init-premount/dropbear: .: line 275: can't open '/run/net-enp1s0.conf': No such file or directory

I can then only proceed by entering the LUKS password at the machine.

A few things I tried:

  • The interface enp1s0 is the one that is shown by ip a once the system is fully booted, but seems to be incorrect in the initram?! I tried to omit the interface name so the initram would figure the correct one out by itself, but then I still receive the ipconfig: no devices to configure errors and the last error changes to /scripts/init-premount/dropbear: .: line 275: can't open '/run/net-*.conf': No such file or directory.
  • I also tried the "standard" interface names eth0 and eth1 but got the same errors.
  • I edited /boot/cmdline.txt according to this answer, but that didn't help.
  • I added virtio, virtio_pci and virtio_net to /etc/initramfs/modules as that seemed to help someone with a similar issue (can not find the webpage anymore), but with no success.
  • I added ip=dhcp to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub as described in this article. No change at all.
  • I created the file /etc/initramfs-tools/conf.d/cryptroot with content target=mmcblk0p3_crypt,source=UUID=49429a5f-f094-485c-8c2e-45f53f81919f as suggested on this Q/A site. (The content of /etc/crypttab ist mmcblk0p3_crypt UUID=49429a5f-f094-485c-8c2e-45f53f81919f none luks,discard,initramfs, by the way.)

My guess is, that either the network is not up or a driver is missing in that initramfs phase or I have the wrong interface name, but I do not know how to fix the first or how to find out the correct name. Any help is appreciated.

1 Answer 1

1

Turned out, that indeed the network driver was missing in the initramfs. The module argument MODULES=most in /etc/initramfs-tools/initramfs.conf was not sufficient. Thanks to this answer, I found my network driver using lspci -v and added the appropriate module to /etc/initramfs-tools/modules. After rebuilding the initramfs, I still receive an error about some module that can not be loaded but the network is running nonetheless and I can unlock the LUKS device remotely.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .