0

I'm trying to install Fedora 32 on my computer, but my mouse pointer won't behave properly. Most of the time, it stays stuck in the top right corner of the screen and gets pulled back there whenever I try to move it. Sometimes, I am able to move the mouse horizontally without issue, but it still remains stuck at the top of the screen. I have tried other mice and keyboards to eliminate a hardware issue, but get the same result.

I also tried CentOS 8 and Ubuntu 20.04 and they had the same problem. SystemRescueCD 6.1.6 does not have this problem.

System specs:

  • Intel Core i7 3.5GHz CPU
  • 16 GB RAM
  • Nvidia GTX 650
  • 2 TB HDD

I eventually managed to click through the installer, updated my system, and installed the Nvidia proprietary drivers from RPM Fusion but the issue still persists.

1
  • Update: There is a device called “PS/2 Generic Mouse” that was generating constant input even though I don’t have a PS/2 mouse. Disabling it with xinput stopped the pulling, but I still don't know why it's generating input. – JM0 Jul 7 '20 at 21:24
0

Apparently there is a bug in the kernel that is causing this to happen. I added a udev rule to have libinput ignore the "mouse" and now I can use my system.

Put the following in /etc/udev/rules.d/disable_bad_ps2_mouse.rules:

ATTRS{name}=="PS/2 Generic Mouse", ENV{LIBINPUT_IGNORE_DEVICE}="1"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.