0

I'm trying to use sshfs to open a remote directory in the Spotify snap application on Linux Mint.

sshfs -o allow_other user@example.com:/remote/dir /local/dir

I've mounted my directory using the "allow_other" fuse option, and the directory opens without having to use sudo in terminal and file explorer. However, when I try adding it as a directory in Spotify for local files, the file explorer gives me this message:

Spotify error

Any advice on fixing this? I've tried modifying the permissions of the folder and "default_permissions" option, no luck yet.

4
  • According to sshfs(1), the option is actually named --allow_others (trailing 's'), and it should be used with -o default_permissions. Have you tried that? – ewhac Jul 6 '20 at 20:45
  • Which users are running sshfs and Spotify (and the file picker you're showing)? Is AppArmor enabled on your system? Also, to make allow_other be effective when used by non-root users, user_allow_other has to be uncommented in /etc/fuse.conf (see the manual for fuse(8)). – fra-san Jul 6 '20 at 21:24
  • I assume it's all running on the same user, since I'm opening Spotify and running sshfs on the same computer (and user). Though the Spotify app is a snap application and I'm not running that from terminal, so could that make a difference? Also, I did already uncomment user_allow_other Also how do I check if AppArmor is enabled on Linux Mint? – Jonathan Ting Jul 6 '20 at 21:29
  • I ran aa-status and saw that a few profiles with snapd in the directory name are in enforce mode. Could that be why? EDIT: One of them is snap.spotify.spotify, – Jonathan Ting Jul 6 '20 at 21:35
0

Seems like snap applications don't allow me to disable the AppArmor protection easily. Thankfully, Spotify for Linux had a 2nd version as a Debian package which didn't have the same issue. Not technically solved but solved enough for me!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.