0

I have trouble trying to customize my z shell with OMZ framework and some other plugins. I am in my zsh, but when I tried to echo $ZSH_THEME, nothing appears. I am suspecting that the problem has to do with permission, but I don't know a whole lot about chmod.

The reason for my suspicion is when every time I log into my shell, I have to source one of the plugins every time I log in source ./zsh-syntax-highlighting/zsh-syntax-highlighting.zsh in order for it to show. Any help would be much appreciated!

EDIT: I also try to add PATH, but it doesn't seem to carry over to the next session.

UPDATE: so I removed .zshrc folder and configured a new .zshrc file. It solved the problem.

1 Answer 1

2

Zsh cannot automatically find which plugins to run, and to tell it to run the plugin when zsh starts, you need to put the source line somewhere in your ~/.zshrc

Eg. add

source ./zsh-syntax-highlighting/zsh-syntax-highlighting.zsh

to the end of ./zshrc

1
  • I had that but it doesn't work :(
    – anguyen
    Commented Jul 6, 2020 at 3:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .