0

I want to do this from commandline: enter image description here

What I've done so far is to create a ~/.asoundrc file with the following contents:

pcm.pulse_monitor {
  type pulse
  device alsa_output.pci-0000_00_1b.0.analog-stereo.monitor
}

ctl.pulse_monitor {
  type pulse
  device alsa_output.pci-0000_00_1b.0.analog-stereo.monitor
}

With alsa_output.pci-0000_00_1b.0.analog-stereo.monitor as the desired monitor source.But it doesn't work because if I launch Audacity and set the source to Built-in ... via pavucontrol and then relaunch the Audacity the default source would be still Builtin ... not Monitor of builtin ...

Is there any way to make it work in command-line ? Note that restarting the pulse-audio server is not preferred because it would cut the sound of all the current clients of the PA server.

Thanks in advance.

0

analog-stereo.monitor is a Pulseaudio source for audio recording. It would not be recognised by ALSA when used in file ~/.asoundrc

to see information about Pulseaudio sinks and sources, including defaults:

pacmd dump

default-source for recording can be set with:

pacmd set-default-source alsa_output.pci-0000_00_1b.0.analog-stereo.monitor

it may also help to remove Built in Analog Stereo as a recording option so only Monitor of Built in Analog Stereo is available

(pavucontrol will not show a drop-down list of sources if there is only one available for recording)

pacmd data probably shows the card-profile as:

set-card-profile alsa_card.pci-0000_00_1b.0 output:analog-stereo+input:analog-stereo

change it to output only with:

pacmd set-card-profile alsa_card.pci-0000_00_1b.0 output:analog-stereo+input

Card profile can also be changed in GUI using pavucontrol -t 5 Configuration tab

change profile in drop-down menu from Analog Stereo Duplex to Analog Stereo Output

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.