0

I am new to the Linux world. I am a chemistry student but since our lab researches on computational chemistry area I need to understand Linux, as the calculations are run on a cluster running OpenSUSE. The thing is I have OpenSUSE 11.4 installed on some machines, and when we reboot them they do not start the ssh daemon right away. Thus the root user (me) needs to run the following command manually: rcsshd start

I am looking for a way to make the ssh start on boot. I do not wish to install systemctl or update the system because I am not an expert, and I am afraid updating might result in problems in the cluster (e.g., communication of one machine with the other, or other sort of problems). Does anyone know how to solve this, maybe a command or perhaps a script that runs the command rcsshd start right after boot?

1

3 Answers 3

3

The OpenSUSE wiki and many other places say to simply use Yast2. Start Yast2, select "System services", and then enable SSHD there.

1
  • Yes, esp. with more inexperienced administrators it's better to recommend use of admin tools/frameworks such as YaST.
    – Juha Laiho
    Jul 5, 2020 at 8:53
1

Asked 1 year, 2 months ago

if you, or anyone still needs an answer...

for SLES or opensuse version 11.4, that is not systemd it is the old SysVInit way.

I am looking for a way to make the ssh start on boot

As root do a simple chkconfig sshd on typed at the prompt and that will cause the sshd service to start automatically upon system boot; you should not have to manually start sshd.

when doing just chkconfig it will report 7 columns worth, representing runlevels 0..6. The SSHD service should show on for runlevel 3 and 5.

I have some sles 11.4 systems still, if you need more detail on this let me know I'll have to go physically check to be 100% gramatically correct {i'm going from memory, i use RHEL 7 now}

-1

One way would be to start it manually in /etc/rc.local:

mkdir -p /run/sshd && chmod 755 /run/sshd
/usr/sbin/sshd

The mkdir/chmod command is to avoid the potential error message:

Missing privilege separation directory: /run/sshd

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.