0

Running Linux Mint 19.3 Cinnamon.


I intentionally deleted the boot log file:

/var/log/boot.log

And re-created it with touch, just changed permissions afterwards, to have it empty:

ll /var/log/boot.log
-rw------- 1 root root 0 Jun  8 08:18 /var/log/boot.log

Now the problem is, it does not get filled with boot info anymore, and I don't have an idea why that is to remedy it?


As for comments section:

  • I checked on my other Linux Mint (20 Cinnamon) there are no special attributes to this file with:

    lsattr /var/log/boot.log
    --------------e----- /var/log/boot.log
    
    ls -l /var/log/boot.log
    -rw------- 1 root root 2049 Jul  3 07:54 /var/log/boot.log
    

    which should mean it's without any special permissions.

  • I also checked if I rebooted with:

    journalctl --list-boots
    -15 3f5663f13f234df59923102846b764e9 Sat 2019-11-02 09:56:11 CET—Sat 2019-11-02 14:08:06 CET
    -14 757f26973c7244ed8bf6f02b0b4652e9 Sat 2019-11-02 15:08:07 CET—Sat 2019-11-02 18:17:46 CET
    -13 a981b3a803b34133b9d9730f28708ac4 Sun 2019-11-03 02:45:17 CET—Mon 2019-11-04 12:35:45 CET
    -12 b4faa6ec9730496eae5dc322031a0802 Mon 2019-11-04 13:35:46 CET—Mon 2019-11-04 16:24:19 CET
    -11 368b07afb11544318ce894068683aff2 Mon 2019-11-04 17:24:19 CET—Tue 2019-11-05 11:22:19 CET
    -10 4d7d72eab5ba4eb2b6ca96661046e16b Tue 2019-11-05 13:58:13 CET—Tue 2019-11-05 14:01:49 CET
     -9 83912b995bda4d2ba2a7cfe61db83f71 Tue 2019-11-05 15:13:02 CET—Tue 2019-11-05 14:17:07 CET
     -8 02d69358dcc24e8797dae48f3c9169cb Tue 2019-11-05 16:16:10 CET—Thu 2019-11-07 08:21:38 CET
     -7 1216d754bca94af2acbc08c90c076f6e Thu 2019-11-07 12:09:49 CET—Thu 2019-11-07 21:00:44 CET
     -6 c6ea1a6ce961459f8b9c6c7296a7f253 Thu 2019-11-07 22:00:44 CET—Thu 2019-11-07 21:13:44 CET
     -5 b5b7c652b3544538ba3eda562f7faee1 Fri 2019-11-08 07:17:13 CET—Fri 2019-11-08 19:11:38 CET
     -4 6365a7707c6c4eadab9f7b3e8178f2a1 Sat 2019-11-09 08:05:24 CET—Sat 2019-11-09 20:58:37 CET
     -3 59f4069d8b6d401ba55a6df733033a1f Sat 2019-11-09 21:58:37 CET—Sun 2019-11-10 00:31:52 CET
     -2 ade61fdf4cab4d6e9295c9cb52258737 Sun 2019-11-10 07:45:49 CET—Tue 2019-11-12 06:35:07 CET
     -1 ae9050210431450f930086399aa70297 Tue 2019-11-12 07:37:47 CET—Tue 2019-11-12 07:13:41 CET
      0 ce372be5cda74462bdd476ee6ecc7e6c Tue 2019-11-12 08:35:09 CET—Tue 2019-11-12 07:38:05 CET
    

    This list is odd, I rebooted just now,... 2019 November? I don't know what that is about. Anyhow, I rebooted just now.

2
  • Changing permissions is not enough, what about gid. Chown it with proper group (wheel perhaps) and retry. Don't mind the "special flag" either when you setuid. Aslo make usre /etc/rc.d /something is still pointing to file (symlink or absolute path, your choice).
    – ares777
    Commented Jul 3, 2020 at 13:20
  • @ares777 Not having this directory on my system: ls: cannot access '/etc/rc.d': No such file or directory. Commented Jul 3, 2020 at 14:22

1 Answer 1

0

Plausible work-around, not a fix!

This command seems to do almost the same job:

journalctl --boot --no-pager

This can be run as normal user (to my surprise). I didn't bother to figer out the colors, but by default only critical seem to be in red color, which is actually a bit better for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .