0

Fresh install Ubuntu Server 20.04. cat /proc/filesystems shows exfat in the output. Not installed any other packages for exFAT as it should work from kernel.

Mounted 2 internal HDDs on in fstab as below

#INT-1TB-4K Internal HDD mount to /mnt/INT-1TB-4K
UUID=0E7E-6579 /mnt/INT-1TB-4K exfat defaults, permissions 0 0

#INT-1TB-BAK Internal HDD mount to /mnt/INT-1TB-BAK
UUID=3037-96B0 /mnt/INT-1TB-BAK exfat defaults, permissions 0 0

/mnt ls-all gives

exharris@plexserv:/mnt$ ls -all
total 520
drwxr-xr-x  4 root root   4096 Jul  2 09:32 .
drwxr-xr-x 20 root root   4096 Jul  2 05:15 ..
drwxr-xr-x  9 root root 262144 Jul  3 03:49 INT-1TB-4K
drwxr-xr-x  7 root root 262144 Jul  3 03:49 INT-1TB-BAK

I get permission denied errors in the terminal when trying to create files in these folders (unless I use 'sudo', of course). This is because the 'others' write bit is set to -.

When running sudo chmod -R 777 INT-1TB-4K from /mnt, I get no errors, but when doing ls -all again, nothing has changed.

This is causing me problems also as I have set these up as Samba shares and also cannot write to them from other machines.

I also tried sudo chmod -R o+w INT-1TB-4K - same thing happened.

What is going on? I do not want to use exfat utils and fuse.

3

exfat behaves just like vfat and since it has no concept of permissions, chown and chmod both won't work.

You have to specify mount options such as uid, fmask and dmask, e.g.

defaults,noatime,nofail,uid=1000,fmask=0133,dmask=0022

(run id to find out what your ID is).

| improve this answer | |
  • Thank you! I read man mount but it had no section on exFAT and used 'permissions' just because that's how I'd done it for NTFS. – exharris Jul 3 at 14:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.