I have a thin PC equipped with a Core i7-8550U on which I am running Debian 10 Buster.

The board uses Intel HD Graphics 620 and has a HDMI and a Display Port on board. No external graphics card. This board claims it can support up to 3 monitors.

I have one monitor (supporting only VGA and HDMI inputs) connected to the HDMI port which is perfectly fine. Since my monitor doesn't support DisplayPort, I purchased a DisplayPort to HDMI adapter. But I simply cannot get the second monitor recognized. I read someplace that the problem may be with the adapter being passive and I bought a second (supposedly) active adapter. I honestly have no way of telling if either of them are really active or passive. I'm just going by what the product claimed on amazon.

I have tried numerous things. I can't even recollect anymore the things I've tried or what driver state my machine is currently at.

Some things tried are

  • with and without xserver-xorg-video-intel
  • buster-backports firmware-misc-nonfree linux-image-amd64 firmware-linux firmware-linux-nonfree
  • buster-backports xserver-xorg-video-intel

One other thing that I tried and failed at completely was drivers from ppa:oibaf/graphics-drivers. Install wouldn't work because the repo was not PGP signed. I really did not put any more effort is fixing that issue.

No luck. I really don't know where I should be looking. here are xrandr and lspci ouputs

$ xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
XWAYLAND0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 480mm x 270mm
   1920x1080     59.96*+

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 620 (rev 07)

EDIT: I disabled wayland and the xrandr output now looks like this.. im just happy to see a hdmi-1 and dp-1 now showing up.. but i still cant seem to get any ouput on my second monitor via DP > HDMI connector + cable

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 1872mm x 1053mm
   1920x1080     60.00*+  50.00    59.94    30.00    25.00    24.00    29.97    23.98  
   1920x1080i    60.00    50.00    59.94  
   1680x1050     59.88  
   1600x900      60.00  
   1280x1024     60.02  
   1440x900      59.90  
   1280x800      59.91  
   1280x720      60.00    50.00    59.94  
   1024x768      60.00  
   800x600       60.32  
   720x576       50.00  
   720x576i      50.00  
   720x480       60.00    59.94  
   720x480i      60.00    59.94  
   640x480       60.00    59.94  
   720x400       70.08  

Happy to provide any additional information to any kind souls out there who can help me get my dual monitor setup working. :)

  • What does xrandr -q (query) say?
    – Jan
    Jul 2, 2020 at 19:00
  • What should I be querying for? Jul 3, 2020 at 5:52
  • Sorry for a confusion. The command is just "xrandr -q". There is no query to be added. The command should list all video outputs, even disabled ones.
    – Jan
    Jul 4, 2020 at 6:34
  • i'm not seeing a difference. same output as xrandr Jul 4, 2020 at 9:13
  • I installed Windows 10 to see if windows would detect the second monitor. no luck. maybe this is just a dead port. P.S. i had purchased this thin PC on aliexpress. I have no information on the motherboard so i will assume for now that i am dealing with a dead or unusable display port. Sep 27, 2020 at 8:39

2 Answers 2


HW failure should be considered as a last option. I have DisplayPort to HDMI adapter. My xrandr output xrandr | grep " connected" looks like this:

LVDS-1 connected primary 1600x900+0+720 (normal left inverted right x axis y axis) 344mm x 194mm
HDMI-1 connected 1280x720+0+0 (normal left inverted right x axis y axis) 698mm x 392mm

That looks like display port is actually listed as hdmi port. So I try:

xrandr --output LVDS-1 --primary --output HDMI-1 --auto --above LVDS-1

... and here we go.


Perhaps your DP-to-HDMI adapter is a passive adapter designed to use with DP++ dual-mode ports only, and the DP port in your computer does not actually have the DP++ capability?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .