0

systemd's automounts are generally working very well here. There is one exception: The VDR program fails to start after a reboot because it can't access its data directory, which is mounted via automount. Automounting that directory is working, but not if VDR accesses it.

From journalctl:

Jul 02 06:30:24 zem systemd[1]: Set up automount srv-vdr.automount.
.
.
.
Jul 02 06:30:25 zem vdr[663]: vdr: can't access video directory /srv/vdr
Jul 02 06:30:25 zem vdr[663]: [663] ERROR: can't access /srv/vdr
Jul 02 06:30:25 zem systemd[1]: Failed to start Video Disk Recorder.
.
.
.
Jul 02 06:30:25 zem systemd[1]: srv-vdr.automount: Got automount request for /srv/vdr, triggered by 709 (exportfs)
Jul 02 06:30:25 zem systemd[1]: Mounting /srv/vdr...
Jul 02 06:30:25 zem systemd[1]: Mounted /srv/vdr.

When mounting is triggered via exportfs, it's working. There is no "Got automount request for /srv/vdr, triggered by xxx (vdr)" or similar line in the journal.

That's srv-vdr.mount … :

[Install]

[Unit]
Conflicts=umount.target
Before=umount.target

[Mount]
What=/dev/disk/by-uuid/66779553-2ea8-4145-aa8c-d6b2582d6f32
Where=/srv/vdr
Type=auto
Options=defaults

… and srv-vdr.automount:

[Install]
WantedBy=local-fs.target

[Unit]
Conflicts=umount.target
Before=umount.target
Before=local-fs.target

[Automount]
Where=/srv/vdr

1 Answer 1

2

The problem was that /srv/vdr has permissions 555. VDR checks if it can write to /srv/vdr, sees that it can't and never triggers the automount.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .