2
  • I have a bluetooth headphones with a mic connected to Linux Mint. On blueman (bluetooth Manager) I am able to see the audio profile selected as A2DP sink so the output is working fine.
  • I know for microphone to work I have to select the profile HSP/HFP but I am not able to select that option and get and error "Failed to change profile to headset_head_unit". I have tried all the hack provided on Linux forum like pulse audio, ofno but none of them worked as I haven't figured out the root cause yet.
  • I am yet to find the steps where I can do this via running a script. I just ugraded to Linux 20 hoping the latest version of Mint would solve it.
4
  • I found this description of an apparent solution for your problem here: askubuntu.com/questions/831331/… As I seem to have the same problem, I tried that out as far as I could, but I encountered the following problems: unix.stackexchange.com/questions/636468/… Let me know if the solution worked for you, please, and if so, how you tackled the problems I list. Thanks!
    – Tsepati
    Commented Feb 26, 2021 at 1:09
  • seems like still no one is able to solve this problem
    – nirav
    Commented Mar 12, 2021 at 9:25
  • I'm able to select HSP/HFP but that does not make any input device active. And actually when re-opening settings it has been resetted to A2DP. Linux Mint 20.1.
    – pirho
    Commented Mar 19, 2021 at 20:58
  • Well a newer version of Mint Ulyassa doesn't have a fix . I am not even sure if its a bug in Mint or just some setting I am missing
    – nirav
    Commented Mar 24, 2021 at 9:12

1 Answer 1

1

I was able to get my AirPods Pro working on Linux Mint 20 by following these instructions:

https://reckoning.dev/airpods-pro-ubuntu/

I wish I understood better what the problem is, but whne it comes to headphone profiles I have no experience or knowledge. All I know is that it came down to "in order for a microphone to work, you need phonesim -- but Ubuntu 20 dropped support for phonesim, so you need to install it from a third-party repository". The link I posted will walk you through installing and configuring phonesim

One caveat that I'm still working through (and Googling which led me to your question): After I followed all of the steps I was able to select HSP/HFP and use my mic... For 5 minutes. Then it reverted to A2DP and wouldn't let me switch back. I found (through random clicking and experimenting) that if I restarted pulseaudio again (pulseaudio -k in the terminal) then I was back to HSP/HFP mode... for 5 more minutes

I'm trying to make sense of why this is happening and I'll update the answer once I've figured out, but hopefully this link will get you started in the right direction.

2
  • The steps mentioned in the link worked . Thanks a lot I have been struggling with this even since the locked down. Just a small correction at one place the path mentioned is not correct . For file /etc/systemd/system/phonesim-enable-modem.service the path mentioned is ExecStart=/opt/ofone/test/enable-modem /phonesim ExecStart=/opt/ofone/test/online-modem /phonesim . its a typo `ExecStart=/opt/ ofono/test/enable-modem /phonesim ExecStart=/opt/ofono/test/online-modem /phonesim
    – nirav
    Commented Mar 29, 2021 at 8:07
  • as the article isn't available at that url, here is the archive web.archive.org/web/20210228024322/https://reckoning.dev/… Commented Apr 27, 2021 at 23:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .