1

I'm having some trouble with a QEMU/KVM virtual machine on my local network.

I can connect to it from the LAN but not WLAN, despite the fact that these networks should forward to each other. This might be a router problem.

However, in order to diagnose this, I am trying to change the network type of my virtual machine manager.

At the moment it is set up to NAT, but I don't think this makes any sense.

I've used things like virtualbox before but I'm new to KVM/QEMU. I don't understand what either of these two things - KVM or QEMU, actually is in detail. The limit to my understanding is they're recommended for use with Debian 10 for doing virtualization.

I have a Debian 10 server setup on my local network and it has a Debain 10 system running in a virtual machine.

I attempted to change the network from NAT to bridged, and I appear to have broken it.

Here are two screenshots showing the changes I made to the network.

default network config

network 1 config

After these changes I can no longer start the VM. See image of error below.

error message

Sorry for the totally noob question - I'm completely new (almost) to this stuff. I know I can manage my VMs with virt-manager, but other than that I don't know of any other commands for configuring/diagnosing stuff.

The network was setup to NAT but I don't think this is a sensible/simple configuration. I use NAT on my router for externally accessible services but this is a seperate issue.

Is anyone able to point me in the right direction with this?

I should perhaps add the following question?

  • How does KVM/QEMU work? Why does it require network "default" to be active?

2 Answers 2

3

Turns out there is a completely not intuitive lightbulb symbol which brings up this window, where settings to do with the VM can be changed, including the network.

If anyone knows how to specify the IP address I would be interested to know how to do that as well because it doesn't seem to be possible with the options given here.

solution

4
  • 1
    I know this isn't a productive comment, but I wanted to post to say thank you because yes, that was absurdly not intuitive. That should be changed. Feb 21, 2023 at 2:10
  • @GrantCurell I was concerned my answer might be seen as overly negative or critical but apparently not. At least others appear to agree this layout is not at all intuitive. Feb 21, 2023 at 10:56
  • I totally disagree. You are setting a virtual network interface and network is also virtual. It makes sense that the option is there. Jul 15, 2023 at 7:14
  • @GedizGÜRSU You misunderstood. The unintuitive part is the lightbulb symbol which is where this menu is hidden. Jul 17, 2023 at 20:38
0

You can create permanent DHCP leases by editing the default network with virsh net-edit default. As an example, here are my network settings for my 2 VMs (the lines starting with <host are what you're looking for):

<network>
  <name>default</name>
  <uuid>d836a341-605b-4ba8-a6ce-edfd7a756bc1</uuid>
  <forward mode='nat'>
    <nat>
      <port start='1024' end='65535'/>
    </nat>
  </forward>
  <bridge name='virbr0' stp='on' delay='0'/>
  <mac address='52:54:00:3d:52:bf'/>
  <ip address='192.168.122.1' netmask='255.255.255.0'>
    <dhcp>
      <range start='192.168.122.2' end='192.168.122.254'/>
      <host mac='52:54:00:b4:7e:ed' name='qemu-windows' ip='192.168.122.11'/>
      <host mac='52:54:00:46:d0:e8' name='qemu-mint' ip='192.168.122.12'/>
    </dhcp>
  </ip>
</network>

After making the desired changes, run virsh net-destroy default && virsh net-start default to restart the network (best done with no VMs running).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .