0

I'm trying to use my bluetooth headset with the HSP/HFP setting (so I can use the microphone) on Arch Linux. I have a Plugable USB 2.0 Bluetooth Adapter and a SoundBuds Slim+ headset. I followed the steps on the Arch Wiki's Bluetooth headset page to get it working: install pulseaudio, pulseaudio-alsa, pulseaudio-bluetooth, bluez, and bluez-utils. I then started bluetooth.service (sudo systemctl start bluetooth.service) and then ran

$ bluetoothctl
[bluetooth]# power on
[bluetooth]# agent on
[bluetooth]# default-agent
[bluetooth]# scan on
[bluetooth]# pair 1C:A0:D3:93:16:5E
[bluetooth]# connect 1C:A0:D3:93:16:5E
[SoundBuds Slim+]# scan off
[SoundBuds Slim+]# exit

where 1C:A0:D3:93:16:5E is the MAC address of my headset. This successfully connects my headset using the A2DP setting. I then try to the change the setting to HSP/HFP. More specifically, I run pavucontrol and go to Configuration -> SoundBuds Slim+ and select Profile to be Headset Head Unit (HSP/HFP). However, after switching to this setting, there is no sound.

How can I get the HSP/HFP mode to work with my headset?

1 Answer 1

0

This issue is well-explained on Plugable's website. The solution is to load a firmware file into the Linux filesystem for the Broadcom BCM20702 chipset (which is what Plugable's adapter uses). In summary, the solution steps from that page are (for kernel version 3.16 or later):

  1. download the firmware file fw-0a5c_21e8.hcd linked from that page
  2. move that file to /lib/firmware/brcm/BCM20702A0-0a5c-21e8.hcd
  3. if dmesg shows a firmware load error (which it did in my case), then change the name of that file to BCM20702A1-0a5c-21e8.hcd

This fixed the problem for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .