6

I use an uncommon keyboard layout (Dvorak, intl. with dead keys), and I'm trying to run a game (Prey) using steam's proton compatibility tool.

Before running the game I switch my layout to QWERTY. The game launches and runs great, except it still uses my default layout (Dvorak) instead of QWERTY. And I can't seem to change it.

I'm pretty sure that proton doesn't use the same keyboard manager as gnome (or something like that), and that's why it doesn't register that I changed layouts.

How do I get I to register my current layout, or make proton use QWERTY by default instead of using my default layout.

My OS is Manjaro Gnome edition.

2 Answers 2

3

We tried dragging the preferred keyboard layouts to "US - Qwerty" on top, and we allowed different input sources per application. One or both of these seemed to help.

2
  • 2
    It seems Wine (which is what Proton uses under the hood) always uses the first preferred keyboard layout, so moving the desired layout to the top is enough. No need for allowing different input sources - Proton ignores the selected keyboard layout anyways. Commented Jul 29, 2022 at 0:17
  • 1
    Indeed "dragging the preferred keyboard layouts to US - Qwerty on top" did the trick for me on Ubuntu Gnome. No need for anything else like Ibus or allowing different input per window. Just this silly layout order... Amazing!
    – RavanH
    Commented Sep 1, 2022 at 14:09
0

If you're running GNOME as your DE, there's a setting somewhere in the language settings (can't recall where), but if you stumble upon a select box where the value is IBus, change the value to None and you should be good to go when you change keyboard layouts

I stumbled here when looking for a solution to the same problem with XFCE

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .