0

I'm having trouble adding some PPAs to my Mint 20 installation. I execute the following command:

sudo add-apt-repository ppa:anonbeat/guayadeque

and get this:

Executing: /tmp/apt-key-gpghome.FCM6QB5Ete/gpg.1.sh --keyserver hkps://keyserver.ubuntu.com:443 --recv-keys 71C004D5C1F0137ADBD5186195FABEFB4499973B
You are about to add the following PPA:
 Guayadeque is a music management program designed for all music enthusiasts. It is Full Featured Linux media player that can easily manage large collections and uses the Gstreamer media framework.
For mor information visit our web site http://www.guayadeque.org
 More info: https://launchpad.net/~anonbeat/+archive/ubuntu/guayadeque
Press Enter to continue or Ctrl+C to cancel

Executing: /tmp/apt-key-gpghome.gHfte0izY4/gpg.1.sh --keyserver hkps://keyserver.ubuntu.com:443 --recv-keys 71C004D5C1F0137ADBD5186195FABEFB4499973B
gpg: key 95FABEFB4499973B: public key "Launchpad Guayadeque Music Player" imported
gpg: Total number processed: 1
gpg:               imported: 1
gpg: invalid key resource URL '/tmp/apt-key-gpghome.gHfte0izY4/home:antergos.asc.gpg'
gpg: keyblock resource '(null)': General error
gpg: key 76F1A20FF987672F: 1 signature not checked due to a missing key
gpg: key 7B1869016E94B574: 1 signature not checked due to a missing key
gpg: key A6616109451BBBF2: 12 signatures not checked due to missing keys
gpg: key 3B4FE6ACC0B21F32: 3 signatures not checked due to missing keys
gpg: key D94AA3F0EFE21092: 3 signatures not checked due to missing keys
gpg: key C8CAB6595FDFF622: 2 signatures not checked due to missing keys
gpg: key 871920D1991BC93C: 1 signature not checked due to a missing key
gpg: Total number processed: 10
gpg:       skipped new keys: 10

Literally no clue. It happened to me while trying to install lightdm-webkit2 too. If I got into the PPA section in Synaptic I can see it gets added, but if I try to see its contents I get an error. Trying to remove it (or anything else for that matter) prompts me to refresh the apt cache, and doing so opens a window that's "waiting for synaptic to exit" which is dumb because that's the program that executes that window. I can't close it manually, waiting does nothing, and I need to close that window without finishing its job and everything else, which does remove it for some reason, but it's not clean. What's going on?

  • Seeing your post here (guayadeque.org/…) leads me to believe that you might want to post a bug report with Mint 20: github.com/linuxmint/mint20-beta – ajgringo619 Jun 25 at 21:15
  • @ajgringo619 Can't do that either because it's archived. I do remember having troubles adding ppas on mint 19 about a year ago tho. And I think the same happened with PoP OS, this can't be the OS fault, I must be doing something wrong. In fact, I just tried to add this ppa: kisak/kisak-mesa and the same happened to me. I can't add ppas at all. – Tomás Ralph Jun 26 at 0:28
  • If all PPAs are messed up, then maybe your software sources are misconfigured; maybe resetting the default settings will help. Go to System --> Software Sources, then click Restore Defaults. – ajgringo619 Jun 26 at 0:57
  • Just did that, didn't fix it. Apparently it is a bug with the latest Mint version. I was talking to someone on the community server so they are aware of the issue. They gave me a command that forces updating from insecure repos in the meantime, because the PPA does get added, it's only that it can't be verified, so it won't let me update or download from it. – Tomás Ralph Jun 26 at 2:10
  • Do you have any non-PPA repositories added to Mint? I'm having this issue too, but only when I add the official Pale Moon repository hosted at opensuse.org. – VHS Jun 27 at 20:12
0

Ok so after asking in every forum in the world, I got an answer on the Mint forums, here.

He said it has something to do with a "partially added OBS repo". Not gonna lie, I don't know what he's talking about, but if you're having this problem then this is what fixed it for me. I'd recommend you remove any PPA that's having issues, and then run this command:

sudo rm /etc/apt/trusted.gpg.d/home:antergos.asc 

Simple as that really, you should be able to add PPAs now.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.