0

I installed, and selected the drivers and it was all sweet for a few days. now i've updated my kernel and the nvidia drivers simply won't load. I've tried doing a apt purge nvidia* and reinstalling. I've tried booting to an older kernel. I've tried swapping between the open source graphics driver and the nvidia one. nothing works.

System: Host: Lola Kernel: 5.4.0-37-generic x86_64 bits: 64
Desktop: Cinnamon 4.4.8 Distro: Linux Mint 19.3 Tricia Machine:
Type: Desktop Mobo: ASRock model: X299 Taichi serial: UEFI [Legacy]: American Megatrends v: P1.20 date: 06/26/2017 CPU:
14-Core: Intel Core i9-9940X type: MT MCP speed: 1200 MHz min/max: 1200/4500 MHz Graphics: Device-1: NVIDIA driver: N/A Display: x11 server: X.Org 1.19.6 driver: nouveau,vesa unloaded: modesetting resolution: 1280x1024~76Hz OpenGL: renderer: llvmpipe (LLVM 9.0 256 bits) v: 3.3 Mesa 19.2.8 Network: Device-1: Intel Ethernet I219-V driver: e1000e Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi Device-3: Intel I211 Gigabit Network driver: igb Drives: Local Storage: total: 6.37 TiB used: 1.63 TiB (25.6%) Info: Processes: 447 Uptime: 1m Memory: 62.52 GiB used: 914.5 MiB (1.4%) Shell: bash inxi: 3.0.32 theironknuckle@Lola:~$

2
  • If you install a new kernel, then you'll want to re-install the nvidia driver so that it'll build against the new kernel. Jun 25, 2020 at 0:14
  • @AndyDalton as mentioned, I have already tried "apt purge nvidia*" and reinstalling. didn't do anything Jun 25, 2020 at 5:06

1 Answer 1

0

do you still have the old kernel ? if you still have it just choose Advanced options in the grub menu you'll see the old kernel and just boot into it

2
  • 1
    this doesn't help at all. regardless of what kernel i use, everything is broken Jun 25, 2020 at 5:45
  • do tested nouveau driver ?? (ts open source driver of nvidia )
    – Ayman0x03
    Jun 25, 2020 at 10:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .