3

So, I think I broke my SSH config and I didn't know enough about how it works to be doing what I did in the first place. I will try to be detailed as possible.

I am in a Databases class and we have to SSH onto the CSUF ECS server shell.ecs.fullerton.edu in order to work on a project using MariaDB. It was working fine in both OpenSSH and PuTTY, as well as FTP using FileZilla. Unfortunately, I decided that wasn't good enough and wanted to try some GUI programs to edit the database, including Sequeler, gdaBrowser, GSQL, LibreOffice Base and possibly more that I have uninstalled and can't remember.

I believe the problem I'm having was caused when I attempted to create an SSH key that appeared to me to be required by Sequeler and a couple others. At the time, I wasn't entirely clear on what this was, or how it worked and I just followed instructions from a github page on how to create one and link it to the github account. I have tried removing the keys (RSA I believe is the name of the type) I created using ssh-keygen and added using ssh-add -d ~/.ssh/id_rsa and eval "$(ssh-agent -s)". My professor advised to also erase the server fingerprint from the known_hosts file in the same folder. Some other forum posts led me to think that perhaps there is an issue with some "keyring" program or another, but I can't seem to find any of them. I was thinking I possibly ended up with a GNOME keyring or something because of the apps I installed, but the only one I seem to have is gpg-keyring. The weird thing is, I also seemed to be entirely blocked from the ecs.fullerton.edu domain even in just the HTTP web browser. I was thinking maybe my gateway was blocked by the remote server or something. But oddly enough I can still SSH on my phone. Using my parent's Windows desktop with PuTTY doesn't work though (I am on my laptop running Arch Linux on a home network).

2
  • Where you using a key when it was working or connecting with a password? Assuming you were using a key, what is left in your ~/.ssh dir for keys? It sounds like you removed/over-wrote/renamed the key you were using for your server with one you created. You just need to use the old one when connecting, or upload the new one to the target server. Jun 24 '20 at 17:50
  • I was connecting with a password at first and it was working fine. My mistake was to make a key just because the GUI software I was trying had a field for one. My professor actually said to erase the fingerprent from known_hosts. But I honestly am starting to think I just got my whole IP banned for repeated login attempts because I can't get to the subdomain at all even when just accessing the teacher's public webpage in browser. Jun 24 '20 at 19:15
3

If you cannot connect to the ecs.fullerton.edu domain over HTTP or otherwise from computers using the same public IP ( your parent's and yours), it is likely the university firewall blocked your IP.

In this case, you could either use a VPN or a proxy server if you have one available to try to reconnect. Otherwise, use your mobile connection to try to submit a ticket to their IT helpdesk to see if you can get your IP unblocked. If you can't do either of those, go sit in a coffee shop or a friend's house and try to connect. Find a different network with a different public IP.

In regards to your SSH issues, you should take a step back and try to access your the shell.ecs.fullerton.edu site with just your password since that was what was working initially ( assuming your IP is no longer blocked if that was the case ). Once this is working, you can start creating your SSH keys. In your Arch terminal:

ssh-keygen -t rsa -b 4096

This will generate an ssh keypair for you. Copy it to the server with:

ssh-copy-id -i /location/to/publicsshkey yourusername@shell.ecs.fullerton.edu

Then, try sshing to the server using:

ssh -i /location/to/privatesshkey yourusername@shell.ecs.fullerton.edu

If the above works without prompting you for a password, then ssh public key authentication is working for you and you can copy that ssh private key into any GUI program your heart desires and it should work.

If you run into issues with ssh remember there is a -v flag that will print verbose information about the connection to you for debugging purposes. Use this, and append extra vs ( -vvv is max) for more info.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.