0

I'm using an old laptop running Xubuntu 20.04 as a server, which sits in a cupboard with the lid closed, using x0vncserver to access it remotely. Recently I had to reboot it, but when it came back up I couldn't control it via VNC. I could see the screen and move the mouse, but mouse clicks and keypresses were being ignored. Further investigation revealed that everything was fine until the screensaver kicked in -- no screensaver and everything is fine, but the moment the screensaver kicks in, it stops responding.

For the moment I've disabled the screensaver, which is not really a satisfactory solution. Can anyone suggest what the problem might be or what I might do to fix it?

Update: It isn't the screensaver. I disabled the screensaver but the screen still blanks after about 5 minutes (despite power settings saying do nothing when lid is closed, go to sleep never, and so on), and at that point I lose interactivity. It used to work fine until I rebooted the other day, and I have no idea what I might have done that would affect it.

0

It wasn't the screensaver. I also tried disabling DPMS using xset, which sort-of worked, but I finally found the correct solution: setting IgnoreLid = true in /etc/UPower/UPower.conf. I have now re-enabled the screensaver and I can still interact with the machine even when the lid is closed. Without this setting, something still happens when the lid is closed despite my saying do nothing when the lid is closed.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.