Since I installed Linux on my old laptop, I cannot access the BIOS menu. I have tried fwsetup but I just get a message saying:

Could not set EFI variable 'OsIndications'.

I have also tried booting into Windows, holding shift and pressing restart and then once on the recovery screen, selecting Troubleshoot -> Advanced Options -> UEFI Firmware Settings and clicking restart. That just says:

There was a problem. Restart your PC to try again. It looks like something didn't load correctly. Restarting might fix the problem. If this happens more than once, you might be able to find help by searching online for the specific error code. Error code: 800704d3.

I have tried spamming lots of different keys on startup, including Escape, F1, F2, F3, F4, F12, delete and shift. None of them work. I used to be able to get into the bios fine before I installed Linux. I have installed Linux on 2 other laptops without any issues but its just this one that doesn't want to go into the BIOS anymore. I have since (accidentally) uninstalled Linux when I tried to resize my Windows partition with a tool which wiped out my Linux partitions. On boot, it takes me to a grub prompt (not grub rescue) that says:

Minimal BASH-like editing is supported.

at which point I type exit which gives me a prompt to choose a boot device, where I can boot to Windows Boot Manager just fine but USB devices don't work. To boot to USB, I have to plug the USB stick in, boot the computer, type exit and press enter, then select the USB device option which takes me back into the GRUB prompt again, where I type (for example) chainloader (hd0,msdos2)/efi/boot/grubx64.efi and then boot and it boots to USB just fine.

I had a quad boot (Ubuntu MATE (forgot which version, it was a few years ago), Linux Mint, Windows 8 (as that’s what came with the laptop) and Windows 10) until a partition manager deleted the Linux partitions. It was a UEFI install. It is an Acer Aspire V11 Touch and a quick google search said the bios key was F2, which didn’t work. I also tried multiple other keys which also didn’t work. I noticed that if I hold escape and function on boot, it keeps turning on and off. Don’t know if that’s a GRUB thing or what. Sometimes if I spam potential BIOS keys while turning it on, the backlight turns on, off, and then back on. I have tried sudo systemctl reboot --firmware on an Ubuntu 18.04 Live USB and I just get a new line on the terminal and nothing happens, it just sits there until I cancel it with CTRL + C.

I just want to be able to get into my BIOS setup which I haven't been able to do since I installed Linux and GRUB.


2 Answers 2


This is a known issue on Ubuntu

Reference Link

Known issues

As is to be expected, with any release, there are some significant known bugs that users may run into with this release of Ubuntu 17.10. The ones we know about at this point (and some of the workarounds), are documented here so you don't need to spend time reporting these bugs again:

Incompatibility with BIOS in certain Lenovo, Acer systems A bug in the Linux 4.13 kernel shipped in Ubuntu 17.10 can leave users unable to update any of their BIOS settings, including their system’s boot order, after booting this version of Ubuntu.

A kernel with a fix for this issue will be available in zesty-updates shortly, but, the Ubuntu 17.10 installer images still contain the kernel with this bug. Users with affected systems should not upgrade to Ubuntu 17.10 or boot an Ubuntu 17.10 installer image until this issue as resolved. Doing so may result in your computer requiring professional servicing in order to restore BIOS functionality.

A full list of known affected models can be found in 1734147.

If you have already installed Ubuntu 17.10 on an affected system, you may not immediately notice this problem because Ubuntu will continue to boot from disk. To verify whether your system has been affected by this bug, create a USB stick with the Ubuntu 16.04 desktop image and try to boot it. If you are able to boot it, your system has most likely not been impacted by this bug.

  • 1
    Thank you so much! Had this issue for ages now so will work on trying to get it fixed.
    – Woodie 07
    Commented Jun 24, 2020 at 17:53
  • You're welcome. Please post an answer if you get a good solution or work around. Commented Jun 24, 2020 at 18:08
  • Thanks again David, just had a go at fixing it today and successfully recovered the BIOS.
    – Woodie 07
    Commented Jul 29, 2022 at 22:37

After 4/5 years of having the issue, I finally fixed it. Thanks to David Kariuki for informing me of the Ubuntu bug report.

I was going to swap out the hard drive temporarily and install Ubuntu 17.10 back onto it so I could install the fix, however that would not work as I could not USB boot from the installer unless I had the GRUB prompt left over from a previous install. Instead, I used a VM on a different computer and installed Ubuntu 17.10 onto an external USB HDD. I then plugged the external drive into the laptop and performed the following GRUB commands in order to USB boot:

  1. exit (bringing me to the BIOS boot selection screen), then Enter to choose the (non-existent) “Ubuntu” boot. I will now be back in the GRUB prompt as it failed to boot into the missing Ubuntu entry.
  2. exit again, which automatically tries booting into the “Ubuntu” entry again and it fails, kicking me back into the GRUB prompt, at which point USB support is enabled for some reason…
  3. insmod part_msdos
  4. insmod chain
  5. set root=(hd0,gpt1) (I think it was this partition, not 100% though)
  6. chainloader /efi/ubuntu/grubx64.efi
  7. boot

Now, I was booted into Ubuntu 17.10 and I could simply install the patched kernel linked in the Ubuntu bug page. In my case, the first one didn’t work but the second one did. After installing each kernel, I rebooted the machine and shut it down again after boot. Then, I turned on the laptop and tried entering BIOS with f2. After installing the second kernel and rebooting once, I could enter the BIOS settings as normal. It also caused the computer to boot straight into the installed Windows 10 instead of to the GRUB prompt first.

  • Thank you @Woodie 07 Commented Jul 30, 2022 at 21:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .