0

I have done quite a bit of digging on this, but I cannot seem to find the answer (maybe I am not searching for the right question).

I have a Wireless XBOX 360 controller (bought of eBay) and I am trying to connect it to Linux Mint 19 (using a wireless receiver, also bought off eBay). The controller is official, but the receiver is unofficial (probably a Chinese import of some sort).

When I first plugged them in, the controller paired with the receiver fine, and ran for about 10 mins, then lost it's connection and had to re-connect. After that, it retained it's connection for less time and then had to re-connect again. It did this a few times then lost it's connection completely and refuses to connect.

When I press the xbox button in the centre, it does it's "searching" animations (as per https://www.partsnotincluded.com/xbox-360-controller-led-animations-info/) but it now never pairs.

In addition, if I press the "pair" buttons on both the receiver and the controller, I get a pairing animation for about 1 second, then it drops back to searching again.

If I run lsusb I get the following output

Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0489:d600 Foxconn / Hon Hai 
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 005: ID 17e9:4306 DisplayLink 
Bus 004 Device 004: ID 2109:0812 VIA Labs, Inc. VL812 Hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 015: ID 045e:0291 Microsoft Corp. Xbox 360 Wireless Receiver for Windows
Bus 003 Device 011: ID 258a:1006  
Bus 003 Device 014: ID 5007:7959  
Bus 003 Device 013: ID 062a:4106 Creative Labs 
Bus 003 Device 012: ID 1a40:0101 Terminus Technology Inc. Hub
Bus 003 Device 010: ID 1a40:0101 Terminus Technology Inc. Hub
Bus 003 Device 009: ID 2109:2812 VIA Labs, Inc. VL812 Hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I tried installing xboxdrv and running sudo xboxdrv --device-by-id 045e:0291 --type xbox360-wireless -l 6 but that didn't help.

Also I tried running sudo modprobe xpad (suggested on an ask ubuntu post), but that didn't help. I am not really sure this would have helped because as far as I can tell, the xbox kernel module is already loaded.

Finally, I have moved the receiver to different USB ports, but it still doesn't pair.

I have got a wired XBOX 360 controller, when I attach that I get the following added to lsusb:

Bus 002 Device 003: ID 045e:028e Microsoft Corp. Xbox360 Controller

The wired controller becomes active (the 1 light becomes solid) and I can use it fine in Steam.

I am guessing that maybe there is an issue with the receiver (or maybe the controller), but I am not really sure if it is possible to test this in any way? I have also tried the receiver on a different computer (also using Mint 19) and get the same result...

Could anyone point me in the direction of what I can do next to either get this working or work out if it is the controller or the receiver?

1 Answer 1

0

OK, in the end I managed to dig up an old Windows Laptop, installed the recommend drivers and test on that, with the same error (device was recognised as a receiver but controllers would not connect).

In the end I just bought a new receiver and it worked out of the box with Mint 19 (both controllers connect and stay connected without issue).

I am guessing the receiver is broken, maybe the antenna is faulty or something. But if anyone else is getting a similar issue, I would recommend just buying another reciever.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .