0

I'm getting the dreaded hash sum mismatch error when running sudo apt-get update:

Failed to fetch http://ftp2.nluug.nl/os/Linux/distr/kali/dists/kali-rolling/main/binary-amd64/Packages.gz Hash Sum mismatch

What I've tried

  • A lot of different mirrors
  • Make my phone a wifi hotspot and run apt-get update. This just used a different mirror
  • Removed everything in /var/lib/apt/lists and then run apt-get clean apt-get update again
  • Changed server in sources.list to https
  • run apt-key to refresh the key

In the end I downloaded the latest kali virtualbox image and still the same!

edit

Downloaded the latest virtualbox VM image and the same again...

Also, maybe related is that it seems I'm unable to clone some git repos anymore:

git clone https://github.com/aircrack-ng/rtl8812au

Cloning into 'rtl8812au'... remote: Enumerating objects: 116, done. remote: Counting objects: 100% (116/116), done. remote: Compressing objects: 100% (76/76), done. error: inflate: data stream error (incorrect data check)B/s fatal: pack has bad object at offset 6162461: inflate returned -3 fatal: index-pack failed

Is there anything else to check for?

0

Kali needs only one line in the /etc/apt/sources.list file:

deb http://http.kali.org/kali kali-rolling main non-free contrib

Edit /etc/apt/sources.list if necessary with sudo nano /etc/apt/sources.list. Comment out all other lines in sources.list by preceding them with a # character and save the file.

Nano text editor keyboard shortcuts
Use the keyboard combination Ctrl + O and after that press Enter to save the file to its current location.
Use the keyboard combination Ctrl + X to exit nano.

Run the following commands to remove the hash sum mismatch error.

sudo rm -rf /var/lib/apt/lists/*  
sudo apt update -o Acquire::CompressionTypes::Order::=gz  
sudo apt clean  
sudo apt update  
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.