Upgrading my Debian 'bullseye' distribution does not work due to unmet dependencies.

Operating System: Debian GNU/Linux bullseye/sid
          Kernel: Linux 5.6.0-2-686-pae
    Architecture: x86

When I try to upgrade my system by using apt update followed by apt upgrade, I get:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gnustep-base-runtime : Depends: gnustep-base-common (= 1.27.0-3) but 1.26.0-7 is to be installed
 libgnustep-base1.27 : Depends: gnustep-base-common (= 1.27.0-3) but 1.26.0-7 is to be installed
E: Broken packages

Does anyone know how to solve this?


2 Answers 2


Since there’s just been a gnustep-base transition in testing from 1.26 to 1.27, involving an upgrade from libgnustep-base1.26 to libgnustep-base1.27, you need to allow package removals during upgrade: use

apt full-upgrade

instead of apt upgrade.


Please check your source list for any broken or unsupported software sources. Then run.

One possible cause of unmet dependencies could be corrupted package database, and/or some packages weren’t installed properly.

Clear out the local repository of retrieved package files.

sudo apt-get autoclean

Resolve dependencies problems

sudo apt-get -f install
sudo dpkg --configure -a
sudo apt-get -f install

Update system packages and Upgrade software packages

sudo apt-get update
sudo apt-get upgrade

Finally run a full upgrade to solve your problem.

sudo apt-get full-upgrade

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .