1

when i compile xhpl i always get the error message: ./xhpl: error while loading shared libraries: libdgemm.so.1: cannot open shared object file: No such file or directory

when i type ldd xhpl:

linux-vdso.so.1 (0x0000007f885e5000)

    libdgemm.so.1 => not found
    libcudart.so.10.2 => /usr/local/cuda-10.2/targets/aarch64-linux/lib/libcudart.so.10.2 (0x0000007f884db000)
    libcublas.so.10 => /usr/lib/aarch64-linux-gnu/libcublas.so.10 (0x0000007f837fd000)
    libmpi.so.12 => /opt/mpich/lib/libmpi.so.12 (0x0000007f834f5000)
    libgomp.so.1 => /usr/lib/aarch64-linux-gnu/libgomp.so.1 (0x0000007f834b8000)
    libpthread.so.0 => /lib/aarch64-linux-gnu/libpthread.so.0 (0x0000007f8348c000)
    libc.so.6 => /lib/aarch64-linux-gnu/libc.so.6 (0x0000007f83333000)
    /lib/ld-linux-aarch64.so.1 (0x0000007f885ba000)
    libstdc++.so.6 => /usr/lib/aarch64-linux-gnu/libstdc++.so.6 (0x0000007f8319f000)
    libdl.so.2 => /lib/aarch64-linux-gnu/libdl.so.2 (0x0000007f8318a000)
    librt.so.1 => /lib/aarch64-linux-gnu/librt.so.1 (0x0000007f83173000)
    libcublasLt.so.10 => /usr/lib/aarch64-linux-gnu/libcublasLt.so.10 (0x0000007f811ad000)
    libm.so.6 => /lib/aarch64-linux-gnu/libm.so.6 (0x0000007f810f3000)
    libxml2.so.2 => /usr/lib/aarch64-linux-gnu/libxml2.so.2 (0x0000007f80f53000)
    libgcc_s.so.1 => /lib/aarch64-linux-gnu/libgcc_s.so.1 (0x0000007f80f2f000)
    libicuuc.so.60 => /usr/lib/aarch64-linux-gnu/libicuuc.so.60 (0x0000007f80d5b000)
    libz.so.1 => /lib/aarch64-linux-gnu/libz.so.1 (0x0000007f80d2e000)
    liblzma.so.5 => /lib/aarch64-linux-gnu/liblzma.so.5 (0x0000007f80cfe000)
    libicudata.so.60 => /usr/lib/aarch64-linux-gnu/libicudata.so.60 (0x0000007f7f345000)

How can i set the link to libdgemm.so.1? i found it in /home/mpiuser/hpl-2.0_FERMI_v15/src/cuda/libdgemm.so.1

Thanks for ur help guys!

1 Answer 1

0

ld, the dynamic linker, searches for files in a number of system folders and also in those contained in the environment variable LD_LIBRARY_PATH.

So, please try the commands

# export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/home/mpiuser/hpl-2.0_FERMI_v15/src/cuda
# ldd xhpl

(The syntax for setting environment variables differs in different shells so please report any error.)

If you are using bash as your login shell, you can add the first line, i.e.

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/home/mpiuser/hpl-2.0_FERMI_v15/src/cuda

to your file ~/.bashrc (ideally at the end) so that from the next time you open a terminal/shell, the variable will be set correctly and automatically.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .