0

Hi I'm trying to launch cal with sxhkd. And it doesn't work, the terminal window is closed right after the command is executed.

I tried to do it using the following:

# launch urxvt 20x8 with cal
super + c
    urxvt -geometry 20x8 -e cal -m

I also tried to set bspwm to open the window as floating with this: bspc rule -a urxvt:cal state:floating but it doesn't have any efect

1

You need to add -hold on urxvt, in order to not destroy its window when the program executed within it exits.

urxvt -hold -geometry 20x8 -e cal -m
| improve this answer | |
  • 2
    The -e option eats the remaining arguments (+hold shouldn't be on the end). – Thomas Dickey Jun 21 at 18:51
  • 1
    ... And I'm pretty sure it should be -hold. +hold deactivates the "hold". – Quasímodo Jun 21 at 19:13
  • @Quasímodo just checked the man page it is indeed a -hold – user419050 Jun 21 at 20:18
  • Thanx guys, I was totally careless. – Krackout Jun 21 at 20:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.