1

Whenever I try and use the microphone on my pc, it gives off this really loud noise. Even when silent, when I go to pulse audio volume meter, it shows that there is some sound when there literally is no sound at all. And since many people have issue with pulseaudio, I thought maybe it was a pulse audio issue but even after uninstalling pulse audio and using alsa, the issue still remains. Any help would be immense.

2 Answers 2

1

Since removing PulseAudio had no effect, then it seems the problem is not related to PulseAudio at all.

Instead, this looks like a possible problem with ALSA mixer default settings for your hardware, or perhaps a hardware problem.

What kind of microphone are you using? Is it a built-in one (like most laptops have) or is it something you have bought separately and plugged in? If separate, have you checked that it works with another computer or other device?

Then check the ALSA mixer settings, using alsamixer or similar. If PulseAudio is installed, you'll normally see the simplified mixer of PulseAudio if you don't specify the soundcard to use with alsamixer -cN where N is a number, starting from 0.

If your mixer settings include "Loopback Mixing" or "What U Hear" or similar setting that allows you to record both incoming audio from microphone and computer-generated sounds together, try turning that setting off: on some sound chips this is a known-noisy signal path (hardware bug).

Also, set the volume slider of any input channel you aren't actually using fully down, and mute the channel if possible: this will minimize the chances of unused audio inputs picking up electromagnetic interference and resulting in noise in your recording. In particular, if your hardware manufacturer has not actually used all the possible inputs in the sound chip and left the unused input(s) without proper termination, those might pick up noise from any number of high-frequency digital signals inside the computer.

1
  • Thanks a lot, I never thought to tinker with alsamixer, after tinkering with some of the options in there, the sound went away completely. Jun 21, 2020 at 10:29
0

Anyone going through the same issue. In my case the problem was with the mic boost. As soon as I muted the mic boost, the sound went away. To turn of the mic boost, get the index of your sound card, and type in alsamixer -c index. Then change the volume of the mic boost to zero.

1
  • The correct amount of mic boost depends on the properties of the microphone. Boosting the signal of a very sensitive microphone will cause noise and clipping in the recorded signal, but a less sensitive microphone might need some amount of boosting to get a useful signal that is not too quiet.
    – telcoM
    Jun 21, 2020 at 12:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .